How to modify a .dwg in sketchup


#1

Hi there,

I’m starting to use Sketchup and I wanted to import a .dwg to make a little 3D. However, once I import it, it seems I can’t modify the plan, I cannot select line and use the “extrude” command (sorry for the english).

When I click on the plan it select all the plan and not the line.

How can I modify my .dwg plz ?

Thank you !


#2

You need to double click on it to open it for editing or right click on it and select Edit Group.
When you imported it came in wrapped up as a group…


#3

Thank you !

(sorry for the “stupid” questions, i’m a beginner…) here is another one if you have time, now that I can edit my plan, i’m trying to fill it with surface to modify it properly but here is what i can get with the “rectangle” tool :

Why can"t i fill the entire area ?

thank you again


#4

.DWG are notorious for being troublesome. They have lots of tiny lines and missing bits that lead to missing faces.
It can be easier to draw from scratch, but there are ways of repairing them.
If you are a beginner you will probably get more benefit from drawing it again than fixing it.
If you really really need to make this one work it is possible, but if you are only doing it make a simple drawing it may not be worth the trouble at this stage.


#5

Allright, well it would be especially for the contour line that i need to use the .dwg
I don’t know how to re draw them on sketchup, the rest would be ok but the contour line… (curve line, i don’t know the right word in english)…

Or maybe if I fill the area with triangle or diagonal (which is pretty muck working) and then I masked them it won’t cause any trouble after for the 3D ?


#6

ok actually it’s not that bad, a few lines are already almost filling the entire area… thank you for your help !


#7

Ok, so you got the idea. It’s a matter of tracking down the gaps.
There are plugins and various methods of automating it but it’s good to understand the basic way first.


#8

Any way I can color my trees (in white) or is it a block i can’t modify please ?
thanks !


#9

You should be able to colour everything. It’s hard to say what the problem is from an image, could you attach the model to check.


#10

Ah it’s ok, I hadn’t used the “explode” command :smile:
thx


#11

Ok that’s good, but be aware you shouldn’t be simply exploding things at random. They are usually in groups for a reason.
Groups and Components are how you separate geometry in SU. So if you explode your tree onto the landscape it will stick to it making it difficult to move. Open the group and edit inside it, including colouring it, then it is still a movable object.


#12

Ok ! yes, better to do it your way, juste 5 minutes after I exploded and colored the tree I try to move it… ahah

Could you tell me what is the difference between the two line weights please ?


#13

The thicker line is a Profile, meaning it is showing the visual edge of something rather than just the line.
One simple way of putting it, if you draw a sphere it will show you the curve of the sphere when you are actually seeing the Profile of the face. They can help to show what is the perimeter of a face and what is a cut through the face. If you draw a square and then draw a line bisecting it you will see the outer lines are thick and the inner line is thin.
You can turn Profiles on and off several ways. In the style edit menu or View/Edge Style/Profile.