How to import ArcGIS Pro dae in SketchUp Pro 2021?

Hello,
I have create a Collada file in ArcGIS Pro from buildings with texture.
When i import this in SketchUp the program crashes or displays the message that the Item is empty.
What’s wrong with this file?

Model.zip (1.3 MB)

ps: in FME i see the building but with no texture.

Hope someone can help me of this.

Best regards

What does the building look like in ArcGIS?

I did an export to Collada from SketchUp, and see that it uses version 1.4.1, which it seems is still in common use. I tried a number of online converters, and none of them coped with your version 1.5 file. Do you have an option to export to Collada 1.4.1?

Having said that, SketchUp shouldn’t really crash, even if it can’t cope with a Collada 1.5 file. I will log a bug report about that.

I’m not sure how Mihai.s opened it, but he may have used Skimp or some other extension.

Colin, I just used MeshLab to import and export as DAE, then in SketchUp I applied the textures.
That’s why I asked what the building looks like in ArcGIS, because it may be much easier to model and texture it in SketchUp directly.

Maybe, the folder structure has impact.
@mihai.s can you upload the exported file from meshlab?

Hi, Jack!
From MeshLab has no texture, but if you export from Blender (also DAE), it has the textures applied, only they are not at scale.

  • DAE from MeshLab: ID_1.dae (26.8 KB)

  • DAE from Blender (put all 4 files in the same folder, 1 DAE, 3 JPG - from the OP’s model.zip): ID_1.dae (30.0 KB)


DAE file from Blender imported in SketchUp (I scaled up the texture by 1000x)

and in Blender, after UV unwrapping and UV mapping

1 Like

Thank you. That’s the good texture.
ArcGIS Pro can only export as Collada 1.5 and SketchUp you say can only import as 1.4.
With FME i also can import and export the dae and then import it in SketchUp (without Texture).
Its strange that Sketchup Pr 2021 not the newest Collada structure can import.
And its not a good solution to use Blender because i don’t have that program and its a extra step.

@lw1

I know that ESRI is starting to utilize the gltf format. By chance, does ArcGIS Pro provide you with an option to export gltf? I believe ESRIs CityEngine has the capabilities although it is not the same application as ArcGIS Pro.

If gltf is an option, there is a free gltf importer available in the SketchUp Extension Warehouse. Extension | SketchUp Extension Warehouse

If you can not get gltf out of ESRI, there are multiple free online services that can also convert Collada (DAE) to gltf.

Ha Chris,
Thanks for the tool! I have tried a lot off online services like Converteer online 3D-indelingen
But the all fail.
Phhhh.
Best regards