How to import 3D autocad geometry without getting component overload?

Hi,

I browsed google and several threads, but feel theres no real solution to this.

When importing 3D Autocad geometry (exported from Revit) Sketchup translates all the Autocad solids into components resulting in component overload. The Sketcup file workes fine until I try to create a new component myself or try to open the Component window. Sketchup then freezes and has to be forced to terminate.

The problem seems to be Sketchup having a hard time handling big amounts of components, so I wonder if there is any way to “tell” Sketchup to translate Autocad solids into groups (instead of components) when importing Autocad geometry? Alternatively a way to make components into groups after import?

I apologise if this issue has been covered somewhere else.

Have a nice day, everyone! :slight_smile:

In a DWG file exported from Revit every Revit object has been converted to a unique AutoCad block, so importing that into Sketchup creates as many component definitions as there are objects in the Revit model.
The most straightforward way is to open the DWG in AutoCad and explode all the blocks down to raw geometry. I don’t remember there having been any settings in Revit that would affect this behaviour. It has been a while since I tried, though. Unfortunately the same goes for the IFC format too.
In Revit you have the option of exporting the model as mesh geometry instead of solids. In my experience this imports into SketchUp faster than the solid option, but the block problem goes nowhere.

Hi,

Thanks for your answer! :slight_smile:

I tried to sanitize the Autocad file before importing. I exploded all blocks (using Quick select a couple of times until there were no blocks left) and purged all and saved the autocad file. When importing the file into Sketchup still solid geometry was translated into components.

Exploding the Autocad solids one more level (into surfaces) just resulted in even more components when importing it in Sketchup.

Any idea as how to get around this component overload is more than welcome :slight_smile:

Hi all,

I found a work-around to succesfully create new components in a file “infected” with this component overload issue. Not really optimal but might be a help untill a proper solution is found.

Simply build whatever geometry you want to turn into a component, select just that, copy and paste (in place) into a fresh instance of sketchup (a new empty file), make the pasted geometry into a component and copy paste (in place) back into the original file. The component is fully editable and functional…

If you’re comfortable getting your hands dirty with Ruby, you can write a script that processes the import to your custom requirements. In this video, I show how I used Ruby to explode some sub components inside of some imported trusses. Might give you some ideas https://youtu.be/G5wFlVlASKo

Skip ahead to like 15 minutes or something in the vdeo

Hi Matt,

Thanks for the link - and the challenge :slight_smile: Must admit that I’m a little uncomfortable messing with stuff like that. It’s very interesting though and I’d like to actually spend time digging into it some day, but unfortunatelly right now time is probably the most limited resource i have, so was more hoping to find a solution working straight out of the box :wink:

But I’ll definately check out the video, just because it’s interesting. Thanks :slight_smile:

One possibility, depending on the geometry, there is an extension called Loose To Groups which does what it says on the box.
So if all your imported components happen to be only touching in the way you need you could explode everything then use loose to groups and all connected geometry would be grouped individually, therefore allowing you to clear the component browser.