How to get rid of Z-Fighting?


#1

Hello everybody!

I am creating a model of the garage. And faced with such a problem that one plane at a department shine through the other. And when I increase the scale, gaps disappear. Although they are in different planes. Look at the screenshot. How can I get rid of it?

PS I for the first time on this forum. Please forgive me if something goes wrong.


#2

You can get rid of that by giving the roof some thickness. It wouldn’t be paper thin in reality.

The edge showing through is so close to the top surface that when zoomed out, the difference in relative distance is almost 0.

Another option if you don’t want to give the roof thickness would be to hide the edge at the top of the wall. Get the Eraser tool, hold Shift and click on that line.


#3

Technically that isn’t Z-fighting it is edge bleed.


#4

Csaba wrote a nice blog post about this:
http://sketchucation.com/resources/tutorials/beginner/315-edges-bleeding-through-geometry