How to delete a face?


#1

Hi, I have this block and one rectangle on top of it. I need to deleted the “window” face in the rectangle. I have seen couple of videos but nothing works for me. I can select the top face of the block and delete it but there never will be the hole in the big gray rectangle. It behaves like it is two different object. I can draw small rectangle into the gray one. If I delete it it will not keep hole. I can delete the face of the inner rectangle but the man face still stays unchanged. How to fix this?

I will send the skp


#2

Perhaps you could share the SKP file? With it we can give you a definitive answer.


#3

OK, how to upload attachment? Or where to upload the skp?


#4

You attach the skp the same way you attached the image. Ah yes I forgot the image thing wasn’t working properly. See below for instructions.
But at a guess, is the block a group or component by any chance?


#5

Hit the reply link at the bottom right of a post. At the top of the edit window you will see an icon that looks like a bar with an upward arrow from it. Click that to upload your file. I would show you an image of it, but there is something wrong with the image upload function on the forum right now and it is rejecting certain types of image uploads.

While waiting for your model upload, here’s a guess: is the white box below the gray face a group or component instance? If so, you can’t modify its geometry without opening it for edit. So, its top face won’t delete while you are working at top level in the model.


#6

It took some time to upload - I thought that the file size will be less if I removed the models. But the textures have 8MB.

http://sourceforge.net/projects/autots/files/hole.skp/download


#7

Hi barracuda, hi folks.

On top of the message window, where you type a post, you see a line of icons. Place your cursor on top of each for a second os so to read its description. You will discover that the seventh from the left, the one that looks like a small rectangle with an upward pointing arrow is labeled “upload”.

Just ideas.

Jean


#8

I see the icon now. Thanx. File uploaded and it is not component, just simple box.


#9

Purge your model, it has 90 something components in it.

The face isn’t flat on the box.

Actually, your box is 200+ meters long which has allowed it to twist.


#10

How did you found it? I mean how did you find it is not on the box? I checked it with Paralel projection and View Front, Right, Back… And zoomed. And how did you found that there is so many components?

Delete the hidden circle. Now it has 16 edges and 7 faces total


#11

The Model info and Outliner show you what is there, not to mention the component browser.

There is a shimmer on the face that shows it is z-fighting, so I used a query tool to check the edges and there are several mm out, which over the whole length allows the face to bend rather than break.


#12

Thanks for explanation. I cleared the components. Do I have the query tool too or could I install it as a plugin?


#13

You can get it here.


#14

Thanks for pointing me on this tool. I installed it and I see this:

What does mean the red cross? Does this mean that here is intersection? While the green pin says it is not intersection? I guess it could be so because it makes sense.

Yet one problem: When I use protractor I see the units are not exact. the vertical edge is ~90° with green axis. How to measure this exactly to see the differences?

Note: But maybe I do note bother. If I see one point is 90° so it is OK, the second is ~90° so it means it is not exactly vertical


#15

You can also use the color edges by axis function to better help see where your lines are. Go to Styles - Edit - Edges. Down at the bottom of the dialog box, chose color by axis in the drop down.


#16

It is still not clear why this basic action does not work for me. I use the Push tool.


#18

I did not create any component or group. All I do is that

  1. I draw simple rectangle. Then I duplicate it and the duplicate is moved upwards on the blue axis. I change the size of the duplicate to make it larger. Then I send it back to place it on the original face. I am using blue axis. Then I click on the inner rectangle select the face and deleted. I think there should be hole in the big rectangle.

  2. Later I have deleted the cube and used the Push tool to recreate the box. And then I try to delete the face again.

The reason why I do the step 1) is that I want to make the shapes compatible. If I just draw a shape on surface I do not know how to find the center point of the face and problems with dimensions…


#20

Notice:
Now I tried the method 3
3) I created rectangle and draw rectangle into it and then push. And the hole is there in the bottom. That is OK. But this is not centered. So the rectangles are not compatible.


#22

I have reproduced the steps what I have described and I found no problem. This was done with the push tool, no rotation and no problem.

So I do not understand why the model in hole.skp was not possible to complete. Probably the box and the face were separated and rotated so it was not possible to fit them.

Thanks for your time and tips


#23

I tried to reproduce the steps but it fails again. I checked the inner rectangle if it fits correctly and it does. The Query tool shows no intersection and displays 4 green pins on the surface.

I uploaded the skp file
http://sourceforge.net/projects/autots/files/kopule.skp/download
Just check Current Scene.

**The Push tool fails. If I pull it down, no hole is created. Why? **