How to clean sketchup and energy plus memory?

Hello. I am now trying to model a house in SketchUp using open studio and energy plus. When I open a new document in SketchUp it already appears with three thermal zones created without doing anything. I have already tried to uninstall and install again but the problem remains. Does anyone know how to solve this? Sketchup version is 7 and energy plus is 6. Thank you very much.

You should probably talk to customer support for Energy Plus about that.

Either the extension is using a template file with these groups already defined (their ID numbers would always be the same,) … or … the extension is creating them “on the fly” when a new model is opened.

So, you can check for extension options and hopefully switch this behavior off.

Or run a little script to delete them (hoping that you don’t confuse the extension.)

ents = Sketchup.active_model.entities
grps = ents.grep(Sketchup::Group).find_all {|g| =~ /^Energy Plus/ }
ents.erase_entities(grps) unless grps.empty?

But I’d second what Dave said.

P.S. - SketchUp v7.0 was released in 2008 long before Windows 10 came around. It was never tested to run under Win 10. If you run into any issues, you may need to run it in Vista compatibility mode. You set this by right-clicking the icon, choosing Properties and switching to the Compatibility panel. Check the box and choose a Windows version from the drop down list.

Thank you very much!! it was great help