How to accurately radius a corner using 2-point arc?


#1

Dear All, I have been getting really frustrated with the new behavior of the 2-point arc tool. There are lots of people out there raving about the ease with which you can instantly fillet many other corners just by double clicking them. This is all great, but the Sketchup bods seem to have forgotten that many people (me included) want to define an accurate radius for that corner.

In SU 2014, you could simply click anywhere on a line, move across to the adjoining line, then move until the dotted line between your two points turned magenta, then you dragged the arc until, again, it turned magenta (signifying tangency). THEN, you could type in any number, hit enter and the arc would be the radius you wanted and still be tangential to the lines.

In SU 2015, the steps of constructing the arc between the two sides is clear, but when I enter a radius, I get this:

So I worked out that,** even though the sketchup dialog is asking for my radius**, I need to enter the letter “r” after my radius (If it was asking me to enter the bulge distance I would understand entering the r, but not in this case).

So after I work that out, I thought I’m home free. However, if I enter a smaller radius than the original, I get an error message telling me the radius is too small.

If I enter a larger radius, it changes the radius but does not preserve the tangency by moving the joining points between the arc and the line to the appropriate place. It seems that, in the new version, the points of tangency between the line and the arc are fixed and can’t move…really???

So I am left with the (much more time consuming) workaround of just going with whatever radius I get when constructing the arc and then using the “entity info” window to change each radius individually. Am I missing something? How come the tangency points can move if I edit the radius using the entity info window but won’t move when I enter a radius value in the arc tool itself? This seems poorly thought out to me. Any insights that would save time much appreciated.


#2

Have you tried scaling up the model , drawing the radius, and scaling back down again?
(or make it into a component, scale up a copy, change the copy, delete the copy.)


#3

Well I’ve tried this on many different scales of model and it happens the same on something tiny as on a building size object.


#4

I just tested it in both SU2014 and SU2015. It works correctly in both but you have to drag the arc out to show magenta before typing the radius.


#5

This is really useful. Thanks for the video. My mistake was assuming you could enter the radius after clicking the third time to confirm the shape of the radius in the same way as you do in 2014. It seems you now have to enter the radius and hit enter while the radius is still magenta.


#6

Just to add to Dave, once you have the radius, a double click near a corner will repeat it.


#7

Yes. It is a little different between the two. In SU2014, you can change the radius after clicking to set the arc but it doesn’t clip the corner off. If you just drag the arc out to magenta, let go of the mouse and enter the radius, the corner gets clipped off as it does in my GIF.

On the bright side, that’s one less mouse click.