How do I turn "snap to" function OFF for dragging texture position

I can’t adjust the texture to where I need it because it keeps over or under snapping, skipping over the specific location I need.

Is “Length Snapping” enabled ?

Model Info > Units > Enable Length Snapping

Yes. Though turning it off doesn’t seem to fix the problem:

Hold the control (cmd) key while adjusting the texture…no snapping.

That doesn’t work for me on a mac for some reason. However, the alt/option button removed the snapping, but it removed both the plane snapping and the historical point snap. Is there a way to remove just the historical point snap, but keep the plane snap?

I think its “all or nothing”? what are you trying to do, maybe there’s another way.

when the texture edit is enabled I get list of options show up at the bottom of screen, maybe mac has alternative options ( including alt instead of ctrl).

oh look at that it does say stuff at the bottom of the window

Good call. Yeah, I think it’s an all or nothing situation too. I did find that I can move the location of the pin (by deselecting fixed pins) and it seems to erase the place marker snap too option.

If you just click on a pin once you can move it (lift it) wherever (rather than all). It’s often handy to move the various pins around when deforming a texture to fit a shape.

very rough sample attached.