How do I change a color associated with a particular layer?

It says that I can do so by clicking on the swatch but all I get is an error chime…
I would like to further differentiate text in my model.

This usually indicates that there is a modal window open somewhere else, that you need to close, before accessing any other window.

You probably have some dialog open offscreen. When you hear this error chime, on Windows you can press ALT+F4 to close the active window.

If it continues to be an issue, you may need to reset the SketchUp workspace:

Window > Preferences > Workspace > Reset Workspace (button)


There are global text color swatch buttons on the ModelInfo > Text panel.
By default screen text and leader text are set to 100% Black.

Then you can change individually text by selecting it, and change it’s color via the color swatch button on the EntityInfo inspector panel.

Make a selection set of multiple text objects and change them as a group via the same color swatch button on the EntityInfo inspector panel. (You’ll see the inspector tells you how many objects are selected, so that you know that any changes made via EntityInfo apply to all the selected objects.)

You can make changes to ALL of either text object type, (later / at any time,) by using the “Select All text” buttons on ModelInfo > Text panel, then making the color change.

In order for text objects to display in layer colors, “Color by Layer” must be active, which is global. Ie, material textures will be off, and faces will also be displayed in layer colors.

Alt F5 just closed sketchup altogether.
I did try the preference> workspace >reset workspace but the chime still happens.
About the Text, I probably was not clear about what I was trying to achieve. I have a lot ~100 of layers and have it organized alphabetically and numerically, so that when I click on the “Name” at the top of the list of layers, it appears in the order I need. I thought if I could get some of those layers ordered by color, I could further control their visibility. The are text layers but I don’t need to change the color of the text themselves. Sorry that I wasn’t clear, and thank you.

It is ALT+F4. And if SketchUp closes, it means that SketchUp’s main application window had the focus.

Well the order of the layer listing does change when you click on the “Color” heading button. A sort order indicator should appear next to the heading “Color” caption, to indicate whether the sort order is ascending or descending. For colors is seems they are sorted on their equivalent RGB integer value.

So are you clicking the “Color” heading button, or individual layer color swatches ?

When you click an individual layer color swatch, does the “Materials” dialog appear so you can edit the layer color ?

Alt F4 closes sketchup too!
When I click on the individual swatches in the layer window, the error chime sounds.

Did you install SketchUp by right-clicking the installer and choosing “Run as administrator” ?

Is the SketchUp icon Properties > Compatibility set to always “Run as administrator” ?

Also, be sure to update to the latest AMD Radeon graphics driver available.

Try switching off some settings on Preferences > OpenGL, restarting SketchUp and see if there is any change.

If you continue to have weird things happen (or not happen) that have to do with graphics, switch to the 32-bit edition of SketchUp. (64-bit AMD and some 64-bit Intel drivers have issues with the OpenGL libraries which SketchUp uses and needs.)

If you have Pro, remove the license first via the “License…” command on the Help menu. Then un-install the 64-bit edition.

After installing the 32-bit edition, re-assign the license if needed.

Will try all of the above, thank you.

Hi Dan,

I did not do this at the time (I was on a deadline and didn’t want to take the chance of seriously screwing things up) but finally got back to it and followed your instructions.
It works now, thank you.

1 Like