How can I adjust the thumbnail image before I save a component to the warehouse?

I looked at the previous threads on this topic but I still do not understand how to adjust the way the component will appear after I upload it to the Sketchup Warehouse. In general, the component does not appear in the warehouse view. If I click the Zoom Extents button I get the image I would like to see. Thanks in advance, Dan

Can you share a link to the component you’re referring to?

Generally, you should see the model they way it was displayed when you uploaded it to the warehouse.

You can find them in the warehouse if you do a search for Trex Elevations (e.g. Trex Elevations Beam…)

Found them. How did you go about uploading them? I downloaded the first one, hit Zoom Extents and then uploaded it to the Warehouse. The thumbnail looks like this:

Note: I made it private so you don’t need to worry about anyone getting it from me.

I think the easiest way to fix the views is to download, adjust the views, and re-upload them.

I will give that a try. Is that what you typically do when you upload a component?

I don’t upload that many components, myself, but when I do, I make sure it is filling the frame the way I would want others to see it on the Warehouse page.

Dave - Did you create a new Sketchup file and then download the component so that that was the only component in the file and then hit zoom extents and re-upload it?

Well, I only downloaded your component and opened it in SketchUp. I hit Zoom Extents and then I uploaded it to the warehouse.

I did a similar thing here with a door component in a model of a house I made. I set the view thusly:

And the image in the warehouse looks like so:

Sorry to resurrect an old thread, but I’m having a similar issue. Two of my components have thumbnails that are rendered at incorrect angles in the 3D warehouse. See:

I have tried:

  1. Uploading them from my initial model
  2. Resetting the axes of my components and reuploading
  3. Importing the components into a new blank file, framing them as I want them to appear, and reuploading

…but still the problem persists. Some of those steps managed to get the model rerendered from a different angle, but it’s still completely incorrect. Can anyone suggest how I fix this? I wonder if there’s some error with the component axes or something.


Best workflow is to have a ‘working file’ where you create one or more components and then do a ‘save as’ or save the whole collection, open the file(s) and adjust the camera to a perspective view, maybe a style with a watermark etc.

You can create a scene for this, but the way it looks in the 3D Warehouse is ‘the last saved view’.

Not sure, there used to be a preferences setting under [menu] Window > Preferences > File
‘Regenerate thumbnails upon saving’

Thanks for the reply Mike.

Thanks for the suggestion, however I just tried making a new scene at the right angle, in perspective view, and also made sure my file was saved. Neither seemed to solve the problem, unfortunately. The rendered thumbnail is still from the “Top” view.

It’s strange. I’ve uploaded a few other components and they didn’t possess this issue.

By this, do you mean you right-clicked on an instance of the component and then invoked the Save As… context-menu function to explicitly save the component to a specified file? From what I recall, this is not equivalent to the Save functions on the File menu.