Help to Fix 3d Model


#1

Hey Could anyone assist me with this…

Not sure why it shows errors when i am trying to print

V1.skp (36.4 KB)


#2

All of the faces are reversed. That might not affect its printability, but it looks wrong. Select All, right-click and choose Reverse Faces.

The arc part is ok, you could select it and make it be a Group, and the Entity Info panel shows it has a volume, so that’s good.

The flat thing has no thickness, and so couldn’t print, it doesn’t really exist in 3D. The divider lines seems to stop it from becoming a solid. So, erase the divider line and then use the Push/Pull tool to give that part at least a tiny bit of thickness. Then select it and make it Group too. Or you can fix the divider and thickness first, then select everything and make it be a Group, Entity Info will still show that it has volume.


#3

Apologies i uploaded the wrong one…
V1.skp (43.6 KB)


#4

Select all and reverse faces using the right-click menu. Then select all and create a group or component. What results should show in entity info to be solid, and should 3D print fine.


#5

Hey,

Thanks for the reply.

Here is the output i get from the 3d printer softwareUntitled-1


#6

That’s odd. Here’s what it looks like in SketchUp after editing as I described. I can’t spot any flaws that should cause problems from the 3d printer software…

Edit: what file format did you export for use by the printer software?


#7

Hey,

I exported to .OBJ file


#8

Try STL. I noticed there was something in the model to fix:

Results of Validity Check.

Entity CArcCurve (1824) has a duplicated persistent id - fixed

Don’t know if that matters?


#9

It may be an issue with the options settings when you export. I found I got strange-looking results in meshlab for an obj export unless I turned off the options for “triangulate all faces”, “export two-sided faces”, and “export texture maps”. Then I got this:

I also tried stl export and it looked ok in meshlab.


#10

Yeah, I saw that too. I don’t know what caused that error, but the fix didn’t seem to affect anything.


#11

Hey All,

As soon as i export as STL it works fine… Very strange but sorted now!

Thanks for all the help and suggestions!


#12

STL is geared towards 3D printing, which OBJ may not be. No doubt the geometry is done in a printer friendly way with STL.


#13

This option will create two faces for every single SketchUp face, facing in opposite directions, so it will obviously ruin every attempt to export “waterproof” solids. Another solid destroyer is the “Export standalone edges” option that will create thin extra faces in place of every visible edge.


#14

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.