Help Needed: SketchUp Showing Inches Instead of Centimeters!

Hey SketchUp Fam,

I’m in a bit of a pickle here! I’ve changed my SketchUp settings to display distances in meters and centimeters, but it’s stubbornly showing up in feet and inches instead. This issue rears its head whenever I try to measure distances of objects, check object measurements, or even input measurements while creating new objects. I’ve tried searching for a solution online, but no luck so far. So, I’m turning to you all for help! Any advice or tips would be greatly appreciated! :pray:

Thanks a bunch!

Are you using the free web version as your profile implies?

Show a screenshot of the Length settings in Model Info.

hi, yes