Help! Failed To Open Document and Unexpected File Format Sketchup2021

Hi guys, please help me out. I’ve been trying to do everything I can to open my files. I don’t know what’s wrong with them but it happened to 2 files. One opens with " Failed to Open Document" and the other opens with Unexpected File Format. I’ve done the ff methods but nothing works. @DaveR @colin if you see this please save me :sob:

  1. Renamed the files - still same error
  2. Moved the files to another drive and renamed them - still same error
  3. Tried opening the SKB file - still same error
  4. Tried importing both SKP and SKB files into a new file. This causes a bug splat crash

My usual attempts to recover anything failed. I have asked a developer to take a look.

It seems that the file is corrupted in some way that makes it not possible to extract the data. Probably not the cause of the issue, but the file was made with SketchUp 2021.1.1, and there is a 2021.1.2 update you did yet get. One of the improvements in that version will help with larger models, though your model isn’t especially large.