Having problems with vertical circles


I have just been making spheres in sketchup free and a strange thing happened. Sometimes when I make the vertical circle and I input a radius of 5 feet, I get a circle that does not have a radius of 5 feet. I know this because I measure the diameter and it comes out to 6 feet and some inches I even had one come out to only 1.2 feet. I do not understand what is happening. Can anyone explain? I was trying to grade my student’s spheres and now I don’t know if it is their fault of sketchup’s fault that the sphere is not the right size.


Anthony Wong

Sounds like pilot error. If you are working with a template using feet, start pulling the circle then let go of the mouse and type 5 and hit enter.

So Like I did that at least 5 times and only one of the five made the correct size. I was set to inches and so put 5’ when entering the radius. You can even see that it says 5’ radius but the dimension of the radius shows. Here is a video. What am I doing wrong if it is user error.

Upload your SketchUp file so we can see what you’ve modeled.

Also the video doesn’t seem to work.

The video was an AVI file. I replaced it with an MP4. Found an online converter to change if from AVI to MP4.

1 Like

Are you hitting Enter/Return after typing 5’ ?

I repeated your steps, and first time I tried it I did get two circles that were not 5’ radius. Tried again, and then it was giving the right size. Don’t know what I did differently the first time.

I’m unable to replicate the error.

yes I am hitting enter after typing 5’.

For me I usually get the right size the first time and then most of the time after that I get a different diameter. From what I can tell it only happens when I try to do a circle that is drawn vertically and not horizontally.

Colin, thanks it is good to know I am not the only one.

Box, can you send me a video of you creating vertical circles? Maybe I will see something I am doing wrong.

Also here is the file if that helps.

thanks for your help,


sample.skp (195 KB)

Using your file and your method with the left arrow to set the green axis I cannot get it wrong.

Then I have no clue what is happening.


Is it possible you are inadvertently moving the mouse during the process?

I dont believe so because I am using a notebook with a track pad. So when I go to input the radius my hands are on yhe keyboard not the mouse pad. Thanks though I will check and be sure.

You didn’t mention the trackpad. I have found them suspect, although Colin does like them.

I do seem to have more luck drawing the correct size circle when I draw the circle in the distance.

Other than times when I’m testing mouse or Space Mouse issues, I do only use trackpad on my Macs. But, on typical PC notebooks I find the trackpad painful to use. They are often smaller, and require a mechanical movement to do a press. Apple’s trackpads use haptic feedback to let you know that you clicked, the actual pressing down is less effort. I also have it set up to take three finger touch as being a mouse down, that way I can do many things in SketchUp without having to press down at all. It’s a very comfortable way of working.

Even on a PC notebook, the good thing about using a trackpad is that you know for sure that you didn’t move the cursor while typing a radius.

I haven’t been able to make it go wrong, after the first time I tried the steps.

Don’t bet on it. My fat fingers have a way of messing things up! :blush:

1 Like

Thanks again for all the help and feedback. I will just work around it. Just a weird situation.

I think the weird part is just Sketchup. For me, it frequently doesn’t do as instructed. As you say you can work around it. It’s just odd it is not consistent one way or the other.