Having an alignment issue, and can't figure out why

I added just the walls and the floor that are currently an issue.

Floor and Walls.skp (185.7 KB)

The dead giveaway is the bounding box not aligned to the geometry. Here I select the geometry and rotate it to vertical.

You have length snapping enabled. Turn it off, it is known to cause tiny errors.
Window/Model info/units.

Thank you! I’m embarrassed I didn’t catch that sooner. Will be turning off length snapping as well.

Length Snapping” seems to be a problem for everyone, but I’m actually curious about why it’s such a major problem.
I’m guessing, instead of typing in the value, like I do, everyone else just follows the length SketchUp gives?


Unless if you are working with very tiny details and have to go down to 0.000000 precision, I don’t quite understand the problem.
For me, if I turn off “Length Snapping”, I just seem to be able to drag my line with slightly less “Inference”.

I don’t mind length snapping either and most of the time don’t bother to turn it off, except for special cases.

I like to consider my self a detail-oriented person. and when i see something that doesn’t line up, it’s drives me absolutely bonkers until it’s fixed. I managed to fix my issue with the walls, but going forward I’m going to re-make my model. I don’t trust anything in this current model, knowing what I do now. I’m just thankful for this community!

3 Likes

I’m going to re-make my model. I don’t trust anything in this current model,

Please don’t just repeat a part of a post.
If you have something useful to add, let’s hear it.

I’m late to the party and I think @squirrel has this sorted, but I thought I would mention another tool to help diagnose nearly invisible angular errors that can be created accidently.

The Edge - Color setting of the current Style can be temporarily set to “By axis,” so edges aligned to the current axis system will be colored the same as the axis to which they are aligned, and any edges that are not in perfect alignment with the current axis system will be colored black and easy to see, as illustrated below:

Hope this helps … someone! :smiley:

The problem with the Color by Axis setting is that it has a tolerance that often lets pass just those infinitesimally small misalignments that ought to be spotted.

4 Likes

Box, how small an angle did you have to rotate that. I have never been able to rotate smaller than an angle of .1

It makes sense that, mathematically, there has to be a tolerance to the Color By Axis setting. I guess the question is “How close is ‘close enough’ to be considered aligned to the axes?” I don’t know that answer, but it appears that 0.001 degree is at least far enough to be considered not aligned.

I went back to the model I used for my illustration and set Window > Model Info > Units > Angle Display Precision to 0.000. I then rotated my cube 0.001 degree on the green axis and the Color By Axis setting correctly altered the edge colors to indicate which edges were no longer aligned to the current axis system.

I then rotated my cube back into alignment, using the snapping to the blue axis. Because of my Angle Display Precision setting of 0.000, SketchUp correctly reported that the magnitude of my angular rotation back into alignment was 0.001 degree.

BTW, @booneyrex, I’m not answering for @Box but I thought your question may have been referring to my post. Apologies to all if I’m incorrect.

My question really didn’t have anything to do with the Color By Axis. It is just that I have had the problem of not being able to rotate to a very small angle. The smallest angle I can rotate to it .1. I have my angle display precision set to 0.000 but I still can not rotate any angle smaller than .1. So I cannot correct when I get a line or a rectangle out of alignment by just .01 or something like that, I have to redraw it.

I don’t know why you can’t. I can certainly rotate to .001 without issue. I can go even further than that but the display precision will only show a tilde because it will only show to 3 decimals.

I thought it might be an ability that was added later than 2017. If you cannot figure out why I cannot then I will just have to redraw. It doesn’t happen very often, so isn’t much of a problem.

Can you add a simple file where you have rotated an edge by the smallest you can.

The biggest problem I have isn’t edges, its rectangles. I can by working at it get a line to rotate. Here is a simple rectangle. No matter what I do, it will not rotate smaller than .1
Untitled.skp (134.0 KB)

Go, Window/Model Info/Units and change the angle unit setting to 0.000
Then try rotating.

I already have it set to 0.000 and will not rotate less than .1