Having a volume filled and not empty


I’m trying to create a 3D model to support lasers. This support has to be a torus and I created several cylinders in it to hollow the lasers in it.
My issue, now, is once the cylinders and their orientations have been placed, it appears the main torus is empty. How could I do to get it empty?
Many thanks for any advice.

If I understand correctly, your concern is that the holes in the two sides of the torus aren’t connected by a cylindrical surface, instead you see into the interior of the torus? I’ll assume you have made components of the torus and the cylinders, since otherwise it is much messier. The top of your screen shot reveals you have SketchUp Make, not Pro (please edit your profile, as that info is relevant to the answer), so I’ll give a method that doesn’t use the Pro solids tools.

To create the connecting surface, you need to copy the cylinders into the torus component (select, copy, open the torus for edit, paste in place, explode), intersect them with the torus (select, Intersect Faces with…Selection), and then delete the extra bits. Because they are in the same context, the walls through the hole will remain if you erase carefully. There is a chance of losing tiny faces if the objects are small, in which case you should use “the Dave Method” of scaling up a copy of the component before doing the Intersect Faces with.

1 Like

In addition to what @slbaumgartner said above, if your arrangement of lasers is symmetrical in any way, you’ll save a bunch of effort by making just one pie slice section + laser hole.

Then use rotate/copy to create the full torus out of however many sections you need. Delete the resulting geometry lines that are along the pie slice edges to result in your desired final part.

Before you use the above method, look closely at how sketchup segments circular geometry in relation to how many slices you need, so that your pie slice edges will line up properly once copied/rotated into place.

Here is a very quick gif just showing intersecting and deleting the bits you don’t want within the same context. I reverse the face of the cylinder so that it shows correctly as the internal face of the hole.

1 Like

Hi Box,
This is awesome! But, as slbaumgartner explained it, I’m using components. So how am I able to do this operation with components? Because in my attempts, this isn’t working if the components are not split…

The reply from @slbaumgartner explained how to do this when using components for the torus and the cylinders. To repeat (with a slight variation):

  1. open a cylinder component for editing
  2. triple-click to select all the connected geometry
  3. copy
  4. close the cylinder component
  5. open the torus component for editing
  6. paste in place
  7. select the cylinder wall and the torus inside and outside walls
  8. intersect with…selection
  9. delete the extraneous bits.

Ok here is a gif version of cut and paste in place on a component.
It looked like your laser positions aren’t symmetrical so I’ve made them different here. So if they are all one component you need to make each unique so you can cut just that each one and paste it.
Also note you won’t find cut and paste in the context menu, I have them there so you can see what I am doing.
The other option is to explode all your spokes and cut and paste them in one go into the ring component and intersect and clean up from there.

Many thanks for this great help. However, I’m a bit confused about the removal of unnecessary parts.
Here is the profile of my laser. It should fit perfectly to maintain the laser.

And, now when I’m making it unique and place it in the circle, edit the intersections, etc. Then, I get something not relevant to what I’m trying to do in regard of the laser shape.

It would help if you attach your model. 7th icon from the left is the upload button.

There is nothing magical about any of this, you just need to make sure all the faces you need are selected when you do the intersect, then just keep deleting the bits that you don’t need, but not the bits you do need.


Yes, I understand, but the issue might come from my laser capsule and its intersections capsule_laser.skp (97.9 KB)

A couple of things. You have the camera set to Parallel projection, it is better to work in perspective.
I can’t see where it is you want the laser capsule to fit from the model you uploaded, but I positioned it at the same angle on the green axis and intersected and cleaned up.

One important point is the scale of your work, SU has problems forming faces when you get edges down in the less than 1mm range, this includes the individual segments of a circle. The workaround for this is to scale up, edit and scale down, or use the Dave Method, which I have used here. I have left the large version in the model for you to see. In this case I only need to scale by 10, but it could be 100, 1000, or even just a random amount as it gets deleted at the end.
Basically, with a scaled up version, position the Capsule and intersect it and clean up, simple as that.
capsule_laserBox.skp (107.1 KB)

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.