Guide lines and endpoints small on iMac 5k screen


#1

hi,
i just put sketchup on my new iMac 5k and noticed that when i am building, the lines appear to be very thin and hardly visible. this is the same issue with the highlighting box and endpoint dot etc. Are you aware of this issue and is there a way to enlarge it? or is there an update coming soon with a fix?


Snap node sizes
Affichage illisible
#2

I’ve also noticed that it is a lot harder to select individual lines and points etc


#3

I have the same problem, although it might help to scale your monitor preferences in the system preferences to Best Retina instead of more space. But 5K is crystal sharp, I like it…

You could also try to adjust your scene preferences. A little bit more line thickness for example.

Good luck!


#4

thanks for the advice. its a shame there is no fix yet. it takes so much longer now lining up and joining objects. :frowning:


#5

This problem has been pointed out to Trimble before. It affects all displays with a very large number of pixels-per-inch (as opposed to just large numbers of pixels) - such as Mac Retina displays, 5K displays, and the recently growing number of PC’s with 4k displays. I assume they are working on it, but at the moment there is no announced plan or target for a fix.

In the mean time on a Mac for SketchUp 2015, you can ease the pain somewhat by using the attached collection of double-size images for the inference engine markers. This suite was assembled by John (driven) during a similar discussion over on sketchUcation. To install it, unzip the collection and copy the png files into

/Applications/SketchUp 2015/SketchUp.app/Contents/Resources

inf_retina.zip (22.5 KB)


Changing the size of snaps?
Are Snap points in Sketchup 2016 for Mac really visible?
#6

thanks for the link!! you have made life a lot easier :slight_smile:


#7

You are welcome! By the way, due to a difference in the way that Windows handles these markers, there is no currently known equivalent fix on the PC.


#8

Thank you thank you thank you! This helps a ton! I just got a MacBook Pro and I was having trouble seeing the inference points. This is much better. Hopefully we’ll see a native improvement in an upcoming version.


#9

Brand new apple newbie her and I’m struggling with the switch from windows.
Stupid question but how do I paste the contents of the zip file into the directory you suggest? I can copy the contents but get no option to paste them. If I drag an drop them the contents of the dirstory disappear


#10

easiest way is to

  1. open 2 ‘Finder’ windows, and position them side by side…
  2. in one ‘Right Click’ SketchUp.app >> select Show Package Contents >> click Contents >> select Resources
  3. in the second window unzip the download file [if not already done] by double clicking…
  4. Select all the contents i.e. click first >> shift click last…
  5. Drag and drop all into the other Finder window [i.e. ***Resources***]

restart SU and they should be updated…

john


#11

Another OS X fix for the small line problem on High DPI monitors is to run Sketchup in low resolution. This forces the app to draw the interface at 1X and then scales it up, which means that the interface should render appropriately. The downside is that things look non-retina in the app, but given that SU is not retina-optimized this really shouldn’t be a problem. That said, an additional upside is that performance should be a bit better in more complex models, given that you’ll be rendering things at a much lower resolution.

To run an app in low resolution find the application in question in the Finder, right-click -> Get Info. In the window that pops up, check “Open in Low Resolution”:

Hope that helps.

c.


#12

The use of the images in inf_retina works well for me in both SU 2015 and 2016 on an iMac Retina 5K display.

The first couple of times I tried to copy the extracted image files to the Resources folder in SU 2015, i was blocked from doing so, even though I am an Admin user. In retrospect, I think I may not have Quit SU, just suspended it, so the files were still locked.


#13

I have copied these inference components into my app folders and that really helps when working with inferences. Thank you. It would seem the iMac 5K is a perfect system for sketch and that Tremble hasn’t optimized for it yet is surprising. How do we request that they do that? Hmmmm.

Also, the lines are a bit thin for my old eyes. I’m going to try to change the scene line thickness - but optimization would be really helpful.


#14

Actually, this is the best temporary fix for my issue - which is that everything is a bit small for my old eyes. I love the iMAC resolution for images, but for drawing on Sketchup, it’s a bit small for my needs. Running it in low resolution seems to be the best solution for now.

Thank you.


#15

Incredible…Sketchup 2016 is out and this has not been fixed. No words.

To clarify: this is not a Sktchup problem just with the iMac 5K, this is an old Sketchup problem on all Retina Displays.


#16

The problem remains with SU 2017. Huh? It’s like Verizon ignoring their voice quality problems with iPhones.

New Make user here. I appreciate the work arounds, thank you to the posters. Should I put those PNG files into the other 2 applications (stylebuilder & layout) and cripple the resolution there also?