Guess what... I can't push-pull!

Hello everyone,

I’m new to sketchup. I’ve been trying to create a model of my new house, so I can play around with renovation options. I’ve watched several tutorials for beginners and I try to follow everything step by step, but there’s always something not going the way it should.

I have problems with push-pulling windows and doors. I’ve read a lot of topics on this, watched a lot of videos, tried to troubleshoot in every possible way. And it still doesn’t frikking work.

This is how I went about it so far: I sketched out the outer walls, grouped them, sketched out the inside walls, grouped them, selected a group of walls to edit, drew out a rectangle, pushed it out, made a doorframe, moved on to the opposite wall of the same group to do exactly the same thing, and, you guessed it, it just doesn’t work. It either pushed out a rectangle all the way out like a tunnel, or it just vanishes and the outlines of the rectangle disappear.

I’m attaching my .skp file. I’ve been having nightmares with lines and cubes and grids and dots, I want it to be over. Please help me.


first sketch.skp (221.8 KB)

Guess what … It works with the right work flow. You need to open the group for editing before you can push a rectangle through to create an opening.

This is not a bug in SketchUp.

Please correct your forum profile. It says you are using SketchUp Free which is web based. This model was created in SketchUp Pro.

I also see that you have some nesting going on. In order to make any modifications to that geometry you’ve got to open multiple grouping levels to get too it. There’s no reason for that nesting though.

Hi Dave, thanks for your response, much appreciated. I changed the topic to Sketchup Pro and removed the bug tag.

I always click on edit group before I start. You see that doorframe on one of the inside walls? That’s how I did it. But when I try to do exactly the same on the wall directly opposite, it doesn’t do it. Can you tell if something is wrong there?

Thank you!

Change your forum profile. That still shows you’re using SketchUp Free.

See the addition to my previous post.

I’ve already changed the topic, hope it shows up right.

Thanks for your help Dave. I’m not really sure how this nesting occured (partly because I’m not sure what nesting is in the first place), could you give me a hint?

Thank you!

Another thing: Open the Model Info>Units window , and while working, turn up your units precision. And turn Length Snapping off.
Use keyboard input instead of eyeballing to draw to exact dimensions. Your door has odd dimensions.
When moving things around and copying them remember that the first point you click is the base point for a move. I don’t know if this is the reason but the interior of your model has many small placement errors, with gaps or overlaps. I suggest that you correct or redraw these before going forward to add any new detail to the model, as it will become more and more difficult as the model progresses.

1 Like

It’s your forum profile, NOT the forum topic. The License Type shuold be Pro Plan not Free Plan.
Screenshot - 11_4_2023 , 7_55_16 AM

Nesting is when you place groups inside of groups. Look at what Outliner shows in my screenshot. It loks like you grouped the geometry and at some point openeed the group for editing, select the geometry and created another group inside the first. And then you did it again. Think of a group (or component) as a container for stuff. In your case you made a container inside a container inside a container. To get to the actual edges and faces you have to open all three of those containers first. There’s no need for more than one container. Right click on the top level and choose Explode. Then do it again to leave only one group.

Have you gone through the tutorials at If not, you should.

1 Like

Thanks for your response. There are indeed a bunch of odd things in my model, honestly it’s a result of many hours of frustration, where I’d compromise when things looked a little bit like how I intended them to. But I understand that it only makes the process more complicated and difficult, so I’ll take the time to calmly clean things up again!

I exploded the groups and it worked! Thank you so much, it makes a lot more sense now. I’ll check out the tutorials that you linked.

I’ll resume to my modelling a bit more informed now. Thanks again for your help, take care!

1 Like

Building on what @Anssi wrote, I recommend that while viewing the SketchUp tutorials you pay special attention to learning about SketchUp’s system of inference snaps. The small misalignments he shows suggest that you are not using inferences correctly, as edges should snap exactly into alignment with each other.

You shouldn’t explode your groups. Everything in your model should be grouped by element and assigned a tag. Using all loose geometry will cause issues.

Group your walls, group your windows, group your doors and so on.

Hopefully you exploded only the unneeded nested groups and not the base level groups.