Grouping Trays

I just upgraded to 2023 and am having trouble getting my trays set up like I had them in 2022. In 2022 if I dragged one tray into the title of another tray it would add tabs at the bottom of the window so i could switch between trays without taking up too much screen real estate. This doesn’t seem to work in 2023. Feel like I must be missing the obvious. I apologize if this has been asked before- I did a quick search but can’t find anything. The help section shows the tabs but I can’t get them to appear


Have you tried creating the new tray the way it shows in the Help file by ticking the chack boxes in the list? In SketchUp 2023 the tick box list looks like this but it’s the same thing.
Screenshot - 1_8_2024 , 10_05_55 AM

Thanks for the quick reply. Yes, using the checkboxes is how I created the trays. Here is a screenshot of 2022 trays vs. 2023 trays. Note the tabs at the bottom that show up on the 2022 trays. This allows me to have one small window and then quickly toggle back and forth depending on what I am doing. The help section shows that tabs are possible but I can’t figure out how to get them to appear.
Screenshot- SKUP 2022 Trays-1-8-24

I see what you are referring to with the tabs at the bottom. There were some changes to the UI and this may have changed. You can, of course, collapse the individual trays. Maybe @colin can comment.

It’s a shame if that got eliminated since it worked great in 2022. Hopefully @colin knows a solution. If not, the help section should be changed to not show the tabs at the bottom.

I guess a work around would be to right click and close one tray and then right click to open another. But every time I do that- the newly opened tray auto docks and resizes so it then has to be repositioned and resized. Is there a way to change this behavior so when a custom tray is closed and then re-opened it appears the same size and location where it was previously located?

Are you talking about clicking on where it says “JAA Working” in the attached screenshot? If so, that doesn’t collapse it. If I double click the title bar it re-docks it to the right but that is the only action I can get from the title bar- and isn’t helpful. The attached screenshot is the smallest I can make the tray but then i have to drag the edge to make it large enough to be usable. I feel like I am missing the obvious… Thanks for trying to help!
Screenshot- SKUP 2023 Working Tray-1-8-24

Dock the tray and you’ll get the tabs at the bottom.

Still no luck. When I dock them, they get even bigger. No tabs. I can autohide but they take up the full screen height.

Back to the previous question- Should they be collapsing when click on title bar? That could provide a workable solution…

Yes, it is possible.

When you drag the new tray over an existing tray, popup “targets” will appear. Pay close attention to these target icons.

The one that you need to release the new tray on is the center one which means to stack the new tray on top of the hovered tray. (Stacked trays manifest as tabs.)

The other “target” icons are for placing the tray beside or above or below the hovered tray.

1 Like

No. This is old pre tray behavior when inspectors were implemented each in it’s own tool window.

Thank you! that worked.

Sort of related- is there a way to prevent the tray from auto resizing (getting larger)? Specifically, I like to keep the tray at it’s minimum width. When Entity Info is expanded and I then select a component the whole tray grows significantly wider. I did a quick search and it looks like this is a known bug- any idea if it will get fixed?

And an unrelated question- changing tags for an entity. I typically draw everything on untagged layer and the move to tags as required along the way or later in the modeling process. Based on habit, I have always done this by selecting the entity then use the drop down from the tags toolbar. That still works except when I am moving something from a named Tag to back to Untagged layer. Or if I accidentally draw something on a tag rather and want to make it untagged- I cannot use the tag toolbar dropdown to move it back to untagged. It does work if i use the drop down in the entity Dialog box. Is this a known bug that will be fixed? Maybe i should start a seperate thread for this? Thanks.

No idea. We’ll just need to keep bitchin’ about it. Sometimes @colin will tell us if it’s already been fixed in internal builds so that we can look forward to the fix in an upcoming release. But this “heads up” is not rigid policy.

Please open a new topic (or add a post to an existing related topic) in the proper category.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.