Graphic Distortion (Now I Know Is Called, "Clipping")

Excuse the title, not sure what to call this or even how to describe. This video explicitly showcases the problem. Having an adverse effect on productivity. :frowning_face:

Any advice on how to remedy this or a workaround? Thanks …

Search the forum for “clipping”. Switch your camera to Perspective.

1 Like

Search the forum for “Clipping”.

Go to menu Camera/Perspective View.

Then Shift+Z or select Zoom Extents from the Large Toolset toolbar.

If that alone doesn’t work, save the model if you have any unsaved changes, restart SU, and repeat.

1 Like

Thanks to Anssi and John. At least I now know what to call this troublesome behavior.

Really prefer to work in Parallel Perspective, but maybe that’s not possible. Is this a graphics card or SU issue ? From the many posts it seems to be widespread.

Parallel Projection views are more prone to clipping because zooming in and out and orbiting may move the camera picture plane inside the model. Usually switching to Perspective and zooming to extents corrects this. You can try returning to Parallel view and repeating the steps if or when clipping returns.

1 Like

You can also create 2 scenes.

One with the camera set to perspective and Zoom Extend and the other with the camera set to parallel and Zoom Extend.

Then, a single click on either scene tab get you to the setting that you need.

If you are not satisfied with a scene, you can fine tune Zoom, Pan and Orbit for each scene. Don’t forget to update the modified scene to keep the changes.

1 Like

Why?

The world doesn’t look that way.

And a 3D app like SU isn’t intended to be used that way.

Use parallel projection for output when needed - typically for plan and elevation views - but perspective for modelling.

Clipping is less likely to happen in perspective.

Not exactly either. It’s a function of the way OpenGL works.

1 Like

I was going to add that when i started with SketchUp, coming from a CAD background, I was more at home with parallel projection, but it didn’t take days of working in perspective for parallel starting to look unnatural. I have never met the kind of illusion where the model sort of inverts and you lose the sense of what is near and what far when viewing the model in perspective. Looking at your short video my brain has a lot of work convincing my senses (or the other way round :slight_smile: ) that the corner where the clipping is happening is the nearest and not the farthest.

4 Likes

I originally wrote:
Having looked again myself, I’m almost certain that it is (unusually) far plane clipping, not near plane. The solid green axis goes towards the background and the blue axis is up, so we are looking down at the front of the model, which is (unconventionally) placed on the left of the origin, not the right.

EDITED
After the following discussion, I realised that Anssi and Box were both correct. We aren’t looking down from the front, but up from the back. It’s a weird orientation of the red and green axes.

But the solid red it to the left, so it’s flipped.

1 Like

My brain resolved it into looking up at the model from below. Impossible to revert that.

You are quite right.

But bizarrely flipped - I can’t get the SU axes to look like that, can you? I think the image must be reversed, either left to right or front to back.

I’m not even going to try, but I suspect it is due to parallel projection and the camera zoom possibly making it flip.

Spot on, as usual, Box.

Furthermore, I can get it that way in Perspective too, as Annsi suggested, by looking up from below.

1 Like

I’ve seen the blue solid and dotted blue axis halves flip when orbiting gets SketchUp’s gravity confused.

I’m not an advanced 3D App (or SU for that matter) user, as to fully understand this statement, but will accept based upon your knowledge and experience.

Funny how the world looks to different people. :upside_down_face:

I will honestly try your suggestion and see if I can break my current habit. I really dislike experiencing “clipping”. It breaks my concentration and is a gigantic non-productive distraction.

Thanks to you and others for furthering my SU education. I am continually humbled by not only the group’s knowledge, but the willingness to help us who are just beginning our SU journey.

Still trying to get my head around the different planes (and camera settings) with respect to my viewing position. Just discovered FOV, which helps immensely when inside the model.

Fair enough. But you are less likely to get it in Perspective than Parallel projection, and if you do get it in Perspective, it’s usually a quick fix - Zoom Extents: either by a click on that icon in the Large Tool Set, or by using the default shortcut Shift + Z. After that, go back to your previous view (again, an icon in the Large Tool Set).

If you’ve been working for a long time, sometimes even that won’t fix it, and you should save your work, close and restart SU.

1 Like