Geometry Deformation - "undo" not possible

Does anyone know the problem. I create a geometry and suddenly (when extruding for example), the geometry tears in pieces and some sides of the object are displaced somwhere in the drawing-space.
Similar to screenshot attached.

Whenever this happens, the Cmd + Z / undo option is strangely no longer applicable …
Does anyone know this issue?

Thanks for your answers…

1 Like

I haven’t seen any reports of Undo not working in SketchUp. There was for LayOut a while back but I think that was fixed. What version of the Mac OS are you using?

What steps are you using to create that odd geometry in the first place? Can you share the model before and after?

It happens during normal extruding, I don’t know yet when or why, the before and after will be diffcult, because the “undo” is not possible as said, I try to upload as soon as it happens again…
Thank you so far…

Extruding with Push/Pull? That kind of deformation shouldn’t happen. What are you trying to model?

Are you modelling something extremely small (like thousands of an inch) or extremely large (hundreds of km)?

You must have had a model to share that screenshot. If you could share that model or the part you showed us, that would help.

Bingo! Now it happened again: I marked the yellow ones to show the steps I did, unfortunately it doesn’t happen the second time, so I don’t know the reason yet…Deformation Bug.skp (107.4 KB) .

What tool are you using for extrude?

For something so small, your model is a long way from the origin. Try doing this with the corner of the component at the origin. Do you get the same result?

FWIW, though, I just used Push/Pull to extrude the back face of a copy of your group and it worked fine.

The only way I can find to deform the shape like you did is to select the back face and use Move tool to move it off axis.

What does it say at the top of the Edit menu right after it has gone wrong?

Screen Shot 2020-04-03 at 15.31.48

It looks more like you’re selecting the back face and using the move tool. Maybe you are looking at it from an angle that hides how far away you’re moving the face? Even if you were, Undo should still work.

1 Like

A remote possibility, keyboard malfunction.

This is also what I thought, but it happens out of nowhere, the issuue with the keyboard “RLGL” mentioned: Is there a shortcut for moving geometry to the origin?

In the drop-down menu under “undo” there is only the step before the deformation, but no undos possible anymore, I can press CMD+Z as long as I want, nothing happens…This is the fact, that made me thinking of a Bug, maybe also caused by plugins?

Are you using Move to “extrude” the shape or Push/Pull. I’ve asked you several times how you are extruding the shape but you have yet to answer the question.

Maybe an extension is responsible. Try disabling them and see what you get.

I always use Push/Pull to extrude, also in that case.
I try disabling the plugins, maybe it helps :man_shrugging:

thank you guys for the support!

Yes there is:

Select what you want to move, start the move command drag the mouse in any direction a small amount, let go of the mouse and type [0, 0, 0] do not forget the space after the coma. Hit enter.

Depending on your computer’s local settings, your system will use the semicolon ; instead of a comma as the separator character in localities where a comma is used as the decimal separator.

Ive been having the same issue since I upgraded to 2020. Never happened before. Has anyone figured it out?


I have the same issue @easyup describes. This happened in 2019 and 2020.

Occasionally, when I use the push/pull tool on a face (either editing a component or new geometry) the geometry deforms. When I select UNDO, the geometry remains deformed.
Further UNDOs only UNDO actions made before the geometry deformed.

The same thing happens to me in version 2018, does anyone have the solution?

It seems to be a problem that is present only when the autosave option is enabled. The fact that undo will not repair the distortion might have to do with V-ray being installed on your machines - when autosave occurs, v-ray updates the materials (and maybe other settings too) making impossible for the undo to repair any recently created damage.

I disabled the autosave function and everything runs smooth now. Curios if this problem is present on machines that do not have V-ray installed.
Also, just as a fun fact, as random as the distortion may seem, I once traced the moved element back to it’s original place, moving only along the axes and the distances were very specific, no odd numbers or anything.

That’s interesting.

It happened again these days, and I tried „undo“ and it worked (!!?), the deformation could be undone, I currently run Sketchup Version 20.2.171

Maybe its fixed in this version? What is yours ctInsnd?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.