Generate Report 2021 - "A set of concatenated strings, deduped with count" issues

Recently upgraded to 2021, missed 2020. Generate Report 2019 was working just fine thanks.
We use the Pro version for work (steel frame building detailing) so this is critical for us.
Issue I’m having is the length of components in the report. With Edit Attribute set to “A set of concatenated sub-totals”, if I select just one component (a welded assembly of sub components) and generate a report, the lengths of all sub components are correct.

If I select multiple components or the entire model then the lengths are wrong. The more components selected, the bigger the length values get! A steel post that should be 2599mm long becomes 36,385mm.

With Edit Attribute set to “A set of concatenated strings, deduped with count” the component lengths produced for the whole model are correct, but the count in each cell is simply redundant (there is a Quantity column for a reason!) and would look silly on a cutting list.

Note also the Entity Description column also does not show the entities description (shows 0) unless “A set of concatenated strings, deduped with count” is selected.
Do I have to generate all reports in 2019? Is there another solution?
These reports were used to produced cutting and order lists for fabrication. I currently can’t do that as easily in 2021…


Hey There

Thanks for the report. I’m the product manager for Generate Report. I’ll send you a private message.


You could use a cutlist plugin. Like OpenCutList

1 Like

I too use reports to generate cutting lists, which after exporting to a .csv file are further tabulated to get a total for materials, so having the count (X) in each cell of a length column appear as a default is a pain.

I totally agree with Dunno 458, that having count appear here is redundant information and there is a reason why we have a Quantities column.

Having count appear in a length column totally stuffs up the column’s use as a length column.

Can I please hear what the solution is to removing count in a length column.

Also, have a complaint about the formatting default. Why is the default not left justified instead of centered? How can I change this default?

Thanks in advance for your help.

Like Dunno.458, this is a critical part of my work flow, so please help.

  • Thanks, Fred


I have noticed the same issue. The count in the cell is indeed redundant and very annoying.
Who decided to add an extra calculated value to a data field, this is not common pratice at all!

Please at an option without this “extra” information if you think it has logic to you, but don’t change something people work with for years. This way all my reports fail to export for production import.

Also I noticed Sketchup has trouble to find the internet connnection, only after restart of program it can find the internet connection. This is trouble with 3d warehouse, generate reports, extension warehouse…

Fred here again. I’m trying to run a report and now Quantity only ever returns “1” as the quantity, no matter the real quantity. Not sure if this is me, or if the report function is under review and it’s just not working properly. Could use some advice as I’m completely stuck now without away of tabulating quantities. - Thanks,
Fred Schultz

Fred, have you tried the Quantity column using deduped with count? I had similar problems I reported above;

Note also the Entity Description column also does not show the entities description (shows 0) unless “A set of concatenated strings, deduped with count” is selected.

I messed about with the various settings for each report field until I got a result. Not like it was before they fuxed it (when you intend to fix something, but you… well… things just didn’t work out), but a result none the less.

Good luck mate.

have you tried a cut list plugin? opencutlist is able to easily and cleanly extract the information you need. and the next version may even give the price and weight of the set. that’s a good reason to get started, isn’t it?

Hey Everyone

We’re going to “un-fux” this just as soon as we can. The goal is to provide an option to not show the counts after the values. We’ll make that the default so it just works again. Hopefully it won’t take too long.

I don’t know the exact history of the ‘Deduped strings with count’ aggregate feature but I think long ago someone dropped the count display but never updated the UI strings. So then along comes me (aspiring product manager) with the grand Idea of making some “improvements” to generate report. I notice the feature doesn’t actually do what the UI says. So we “fix” that and break everyone’s workflows. Again, I’m very sorry that we didn’t catch this in beta testing.


1 Like

I was just about to have a winge about having the quantity in brackets in my count also, but it looks like this is going to be addressed.
Every material list I create I have to go and delete the number in the brackets so my excel spread sheet works, and I usually have around 60 or 70 components so It’s a laborious task and one I could do without.
Hoping this gets fixed soon…



Hello Bryce,

Glad to hear Someone from SketchUp is on this issue.
Can you please give us an update on this and when we as a community should expect to see this fix come through?
Our systems heavily relies on this fix so an update would help to manage our workflow on our end.

Thank you,

Any update? Maybe I’m missing something, but the new way the report generator works (intentional or otherwise) makes no sense. Users are going to have to do a bunch of text manipulation on the CSV file to strip out the redundant text information for reporting …

Even if the change were an improvement, changing how the report generator works without any notice explanation or documentation is a crazy unprofessional process, even if you didn’t have a large user base depending on it.

This is a high priority for me, but even more so for users whose business depends on this working consistently. In my view at the vey least we need to know how this will be resolved … and regular updates.

1 Like

The last PM I had from @Bryceosaurus (almost 4 weeks ago) indicated they hoped to have it fixed in a month or two. In the meantime my best option was to Generate Report’s in 2019.
Which is… painful.

Hi Everyone!

Crazy timing! I just saw the fix today. We’re going to be testing through tomorrow then I should have a good sense of when we can push it live.

Here’s the new option which replaces the old option in existing reports

Here’s a tiny report showing that both are still possible. Tshirt Size is with the new fix, Volume is the old way.



Great news, thanks for the update!

In the meantime I may have a workaround … I think if you don’t use the “Group By” selection box in the “Edit Template” screen (i.e. just add the required attributes to the “Report Attributes” selection box) you seem to just get the data “unduped” without the totals in parentheses.

You can download and paste the data from the CSV file into Excel and it is super easy to use auto-filter (or GetData to automate) to filter and manipulate this data without having to edit the data using text functions to remove the superfluous totals in the attribute fields.

If I understand correctly (not guaranteed!) I think this approach allows you to simply dump the model data in a raw form and directly use Excel (which is designed for the data manipulation job) to produce/format a report

This may be a better approach in the long term anyway for some uses … just use Generate Report to spit out the unformatted data and use a preformatted spreadsheet (or the GetData functionality) to produce and print /save the report.

As you can see, I am a noob so I may be missing some stuff, but this will work fine for me! Corrections and comments very much appreciated!!

Hi All

The new option was pushed live! Please check it out and let me know if you encounter any issues. Existing reports should change over to the new option which does not display the counts.


1 Like