Fredo6 check update link broken?


anyone else having this issue in su2024 ?


your libfredo is out of date. so is mine in fact.

it’s now 14.3b. but even with 14.2o on my side it works
try updating it then restart and check again ?


yep, a handful of updates later, it’s all green.

Thanks, yes. I tried updating tools from the Sketchucation plugin but it didn’t do the job so I manually downloaded the rbz for the latest libFredo and opened it as a zip and copied the files over… it now works !
Very odd, but thanks :slight_smile:

You may need to manually download newest Sketchucation rbz and update it manually too…

2 Likes

Actually, the Check Plugins For Update was broken due to the recent change of the Sketchucation forum to a new framework.

You just need to migrate to LibFredo6 v14.3b. And if you use SU2024, you will need also to upgrade to Sketchucation ExtensionStore v4.4.0 and upgrade almost all my plugins to their latest version.

Yes, the Sketchucation Extensionstore was already good, that was my first reflex, but once the LibFredo6 was up to date, the checking worked and I manually updated all the rest.
Thanks to you all for the pointers !
All the best.

Why didn’t you use the Sketchucation Extension Store tool to install LibFredo6?

I’m guessing here, but he probably copied the plugins from 23 to 24.

doing this “broke” the link with sketchucation and therefore it didn’t see anything to update.
I just had a similar situation this morning between the two messages, after updating libfredo, I suddenly had to update my 5 installed plugins. but sketchucation didn’t see them as updatable. Because they were manually copied in the first place.
(I had already reinstalled libfredo last week, so sketchucation recognised it it)

using sketchucation to reinstall them fixed the link.

I tried & it didn’t work.

exactly right, given the number of plugins to migrate, and on several computers manually reinstalling them would take a week, hence the copy over from 2023 !

If you installed your extensions using the Sketchucation Extension Store tool in the first place and then installed the current version of it when updating to SU2024, you could have the tool install the latest versions of all of your extensions from Sketchucation in a couple of button clicks. Installing them manually, however, won’t generate the bundle for the Sketchucation tool to install.

I guess I can see that if you did as you described above and unzipped every RBZ and copied the files into the Plugins folder manually. Install Extension in the native Extension Manager would save you steps.

Well, it’s a bit late now as most of the plugins we’ve been using for years, so had I known years ago…
Anyway, all good now, problem sorted.
Have a good weekend all !

I’ve just upgraded from 2023 to 2024 and am having problems with Fredo6 Bundle I think I’ve installed them all into 2024 - well, all the icons are there and I’ve restarted 2024 several times BUT they don’t work. For example, if I select an object and click on Fredoscale box stretching nothing happens the blue frame remains but no “stretch handles” appear. The same sort of thing happens with Round Corner. I select the shape and click on the round-corner icon but nothing happens. Could this be that I still have Fredo6Bundle on 2023 which is still on my PC or am I doing something wrong? Do I need to remove the FredoBundle from 2023. Can anyone help, please?

Did you also install the necessary Libfredo file and update the Sketchucation tool.

1 Like