Firefox can't establish connection to server


I have installed Sketchup studio on my mac M2, it requres login via trimble web but after successful logging in it shows “Firefox cant establish connection to server” on localhost. I have tried it on other browsers as well and on Windows machine as well and same error appears everywhere.

If it’s happening with other browsers, too, I would start to wonder where the server is and where you are.

I have installed SketchUp Pro 2023 and trying to log into it. Its the trial version. The successful login should redirect to the desktop app. Do we need to set up server separately?

what country are you in, do you use a vpn, or a blocker on your router, or any other security measure that would explain why you can’t reach trimble’s connexion page.

that’s what Dave is asking I guess.

1 Like

I am in Pakistan; not using any VPN or security measure. I can reach trimble’s sign in page and this screen appears after successful login

Something is wrong with redirection to the app

Sometimes may be seen as being an Intranet address. Try changing that part to be locahost instead. In the example you gave you would make the address be localhost:53466/signin?token, etc.

Colin, this is SketchUp’s login protocol creating the URL.
How would a user tweak this? Is there a URL in the preference files, or the i18n dat file?

When the problem happens, the URL is sat there in the browser window. You can edit it and press Enter.

1 Like

Already tried; didn’t work.

I checked, and there isn’t anything in particular about Pakistan that should cause a problem, but you could try VPN into another country, see if that then works.

One of those shield or DuckDuckGo icons look exactly like the kind of extensions that would block a localhost connection

I have tried it on a browser that has no extensions.

1 Like

I dont think so its a VPN issue as the connection is trying to happen on the localhost

Another possibility is at the server side. I think that address is the license server demon that SketchUp runs in the background on your computer. Maybe for some reason it isn’t running? I’m not at my computer so can’t check now…

I presume it’s the webhelper process?

Yeah this is happening most probably; license server daemon is not working locally due to which localhost address isnt resolving. I have checked the address using netcat as well and it is not working

Any solutions please; I really am looking forward to buy sketchup subscription but if trial days goes wasted like this I wont be willing to spend money on it.

Sketchup studio is available only for windows, but if you want to get vray, it’s a bit cheaper if you get the studio version, you won’t be able to use the other tools included, Revit importer and scan essentials.

I have a windows machine as well on which I am facing the exact same issue. Both are running high grade hardware.

The issue is with your server or internet connection, it’s not related to sketchup, you could have the same issues with other softwares asking for a subscription license.