File Locations "Components" is not shown in Components Browser


#1

I can’t get my Components Folder shown in Components Browser, that is frustating me. My current workaround is to share every component so I can access them over components browser with “My Models” location. This is pain because the “My Models” location is very slow loaded and I have to select refresh a couple of times to get the latest version of an component.

I setuped in Sketchup 2015 Preferences -> File Locations -> Components : T:\# Sketchup System Perferences\Komponenten. In T:\# Sketchup System Perferences\Komponenten I have exported components and 2 directories. One directory Dole has already an copy of an component file Wandschiene.skp. In Compontents Browser I can’t see any of these files and directories there. I restarted Sketchup 2015 without any change to the component browser. I check the Preferences -> File Locations after the restart to check if my settings are permanent and yes they are permanent. I exported also File Locations Settings.

[Accelerator]
Count=21
0 0 0 H selectDollyTool:
0 0 0 I selectImageIglooTool:
0 0 0 O selectOrbitTool:
0 0 0 Z selectZoomTool:
0 0 1 Z viewZoomExtents:
0 0 0 A selectArcTool:
0 0 0 C selectCircleTool:
0 0 0 E selectEraseTool:
0 0 0 B selectPaintTool:
0 0 0 P selectPushPullTool:
0 0 0 R selectRectangleTool:
0 0 0 Space selectSelectionTool:
0 0 0 L selectLineTool:
0 0 0 K Ansicht/Kantenstil/Hinterkanten
0 0 0 M selectMoveTool:
0 0 0 G Bearbeiten/Komponente erstellen...
0 0 0 T selectMeasureTool:
0 0 0 F selectOffsetTool:
0 0 0 Q selectRotateTool:
0 0 0 S selectScaleTool:
1 0 1 V Edit/Paste In Place
[File Locations]
Models=T:\# Sketchup System Perferences\Models\
Classifications=T:\# Sketchup System Perferences\Classifications\
Components=T:\# Sketchup System Perferences\Komponenten\
Materials=T:\# Sketchup System Perferences\Materialien\
Styles=T:\# Sketchup System Perferences\Styles\
Textures=T:\# Sketchup System Perferences\Texture images\
Images=T:\# Sketchup System Perferences\Watermark images\
ImportExport=T:\# Sketchup System Perferences\Export models\
ComponentBrowser=D:\Applications\SketchUp\SketchUp 2015\Components\
ComponentBrowser1=D:\APPLIC~1\SketchUp\SKETCH~2\Components\
ComponentBrowser2=C:\Program Files (x86)\SketchUp\SketchUp 2014\Components\
MaterialsBrowser=D:\Applications\SketchUp\SketchUp 2015 EN\Materials\Colors\
MaterialsBrowser2=C:\Program Files (x86)\SketchUp\SketchUp 2014\Materials\
StylesBrowser=D:\Applications\SketchUp\SketchUp 2015 EN\Styles\Default Styles\
StylesBrowser2=C:\Program Files (x86)\SketchUp\SketchUp 2014\Styles\

I checked the forum for getting an answer or something similary to my problem but I have not found something related to this problem.

Sketchup Version Information:

SketchUp Pro 2015
Version 15.3.331 64-bit

I attached an explaining screenshot of my setup and my files and what I’m expecting to get.


#2

This is the path, that is opened when you right-mouse-click (a group or selection) and choose Make Component from the popup context menu.

It does not change the Components Browser base “Components” folder path.
On my machine I have this path set to:
%USERPROFILE%\Documents\SketchUp\Components Master\

*It helps if the name of your custom “Components” folder is named different than the SketchUp program “Components” folder.

You need to:

(1) Components Context menu > Open or create local collection…
Browse to your custom Components folder on T: drive, click OK button

(2) with this new collection folder selected
Components Context menu > Add to favorites

(3) close and restart SketchUp


#3

If you want all of your custom component sub-folders on the T: drive to appear as if they were actually in the SketchUp program’s components folder, you can fool SketchUp with a symbolic link.

You must be logged onto your computer as an Administrator with full permissions.

Then you open a cmd shell and use the mklink command.

Creates a symbolic link.

MKLINK [[/D] | [/H] | [/J]] Link Target

        /D      Creates a directory symbolic link.  Default is a file
                symbolic link.
        /H      Creates a hard link instead of a symbolic link.
        /J      Creates a Directory Junction.
        Link    specifies the new symbolic link name.
        Target  specifies the path (relative or absolute) that the new link
                refers to.

FYI: You cannot write batch files (nor use shell commands from Ruby,) for Regular Users to create symbolic links with the mklink command. Windows does not allow this. Only Administrators can.


#4

:relaxed: Thanks @DanRathbun. I known already mklink and used it common. I thought that there is an more confortable solution with sketchup self like an configuration parameter over an user-configuation file. I have not know the difference between Create a Component and Component Browser -> Components for their storage locations. Thanks for the explanation, worth to know and understand.

I think it’s an topic which is not explained anywhere else in the internet, so I created an schreenshot to illustrate how I got this issue solved in the hope to help others. I ended up with an junction Link to get what I expected:

I can give an addtional tip back:

There is an Link Shell Extension which has the goal to create these kinds of links over the context menu of Windows Explorer. To create this custom setup via an batch file is an wisdom for sharing the custom setup to an other user or computer or to automate it. This is usefull if create often individual Symbolic/Hard/Junction-Links.

I found the following caves while I was finding the above illustrated solution which fits best to me:
I tried different kinds of links (symbolic link, hard link, junction) to get what I expecting.

  • Components-Directory as Symbolic-Link Directory via mklink /D "D:\Applications\SketchUp\SketchUp 2015 EN\Components" "T:\# Sketchup System Perferences\Komponenten" does not work with Sketchup 2015. Sketchup 2015 hides the Location Components in Components Browser.
  • Components-Directory as Directory and with Sub-Directories which are Symbolic-Links via mklink /D "D:\Applications\SketchUp\SketchUp 2015 EN\Components\Dole" "T:\# Sketchup System Perferences\Komponenten\Dole" does work with Sketchup 2015. Sketchup2015 shows the Location Components in Components Browser and shows the Sub-Directory Dole. The components in Dole are shown and can be used with Sketchup 2015. (Please be careful when you copy a directory with a symbolic link, the symbolic link to a normal empty directory is converted. The symbolic link is lost. (Windows Explorer))
  • Components-Directory as Hard-Link via mklink /H "D:\Applications\SketchUp\SketchUp 2015 EN\Components" "T:\# Sketchup System Perferences\Komponenten" was not tested by me, because it is not possible to create an Hard-Link to an target on an different hard-drive/iscsi drive. If the target is on an the same hard-disk the link can be created via mklink but if this works has to be tested.
  • Best Solution is to create an Link of kind Junction. More Informations about Junctions can be found on Wikipedia.

:relaxed: Thanks @DanRathbun to point me in the right direction.

I hope this helps someone else. I had this pain a long time since I learned sketchup and started to use it regulary. Never found an Tutorial or an help topic about this.