FBX export adds random sphere to 0, 0, 0 coordinates

export
fbx

#1

When I export to .fbx file, then import to unreal editor, it adds a random sphere at coordinates 0, 0, 0. It also rotates the model 90 degrees, but that’s simple to work around. Please help. Thanks.


#2

There isn’t a lot to work on in your original post. Can you upload the SU (.skp) file, at least, and perhaps the output .fbx file, please? Use the seventh icon above where you post if the file is under 3MB, or post it on the 3D warehouse or a file sharing site and provide a link, if it is too big.


#3

sketchupmodel.skp (76.8 KB)

Apparently, .fbx files are not authorized to be posted here.


#4

Can you share screenshot of your Unreal Engine showing sphere at 0,0,0?
My wild guess will be that you’re seeing ‘gizmo’ sphere at the origin. It’s just an indicator for you to move stuff around and not an actual geometry. Hit escape to deselect anything, you’ll realize it disappear…


#5

I think you’re right, it might not be part of the geometry. It disappears when I hit play, and it’s not highlighted when I select “Mesh1 (inherited)” on the right. It doesn’t disappear when I hit ESC though.


#6

Seems it’s a different issue than my guess. Check this link and try that suggestion: https://answers.unrealengine.com/questions/571988/how-can-i-remove-defaultsceneroot-white-sphere.html
I don’t know exactly what causes that though.


#7

I think that should work. Thanks.


#8

Some 3D environments use Y up coordinates (instead of Z up as SketchUp does.)

From the Export file dialog, select the FBX filetype, then you can open the Options…
and check the box (in the Scale group) to swap Y and Z coordinates.


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.