Failed to checkout V-Ray for SketchUp license


Hi everyone,

I recently updated to SketchUp 2023 and updated to V-Ray 6 for SketchUp. I am now continuously having an issue appear when trying to access V-Ray. I have tried redownloading, but it happens again once I exit SketchUp and reopen SketchUp and Vray. I run the software on a MacBook Air M1 2020 macOS Ventura Version 13.4.

This is the message appearing:

Failed to checkout a V-Ray for SketchUp license.

Cannot connect to Chaos License Server.

  1. There might be no connection to the Internet or to the computer running the license server.
  2. The VRLService / license server might not be running (by default accessed via internet browser http://localhost:30304)

Would you like to be redirected to the Chaos License Server web interface?

Things I’ve tried:

  • Logging into Chaos Cosmo, but that hasn’t made any changes to the error
  • Accessing the localhost website provided, but I get the error message "Safari can’t connect to server. Safari can’t open “localhost:30304” because Safari can’t connect to the server “localhost”.
  • Opening the Chaos Group installer and V-Ray installer, but they both give the error code “The installer is missing the installer binary and has none specified on command line”. I have attached two screenshots showing the errors.
  • Downloading the Chaos License Server, but I got the error code “” can’t be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information.​

I have submitted a request with Chaos Support, but I have a project due tomorrow and desperately need a quick response. I have attached a screenshot of all the error codes.

Thanks in advance

Screenshot 2023-06-11 at 1.31.54 PM

Are you signed into the Chaos license server on your computer?

Hi Kate, did you ever get this resolved? I am having the same issue.

Hi Danielle,

I downloaded the Chaos License Server and that worked for me the first time but the issue did occur again so I followed a few steps provided by Chaos.

Also if you are having issues accessing localhost try these steps first, and removing my extensions on safari/chrome solved that issue too.

Let me know if this helps :grin:

Download link:

Other steps (if using a mc)

  1. First uninstall the license server. Click on Finder then navigate to Applications → ChaosGroup → VRLService → OLS → uninstall. Doubleclick the Uninstall icon enter your user`s password if required and follow the instructions of the uninstall wizard.

  2. When the uninstall of the license server is complete click on Finder again then on the drop down menu Go → Go to Folder.

  3. A popup window will appear type: /Users/TYPE_YOUR_CURRENT_MAC_USER_HERE/.ChaosGroup inside and press the Go button.

To see the user you are currently logged in on your Mac (the one you need to type above), go to System preferences -->Users & Groups.

  1. After that just right click on the .ChaosGroup folder and select Move to Bin. Note the dot “.” in front of Chaosgroup in the name, that means the folder is hidden. If it doesn’t look the same as in the screenshot on your Mac simply select the column view.

  2. Now login to our website and download the latest version of the license server from the link below:
When the download is complete double click the installation file (or right click and select Open if it shows a warning and you have only Ok button) click Next and then click on the Customize button, uncheck the “Activate during installation” box, leave everything else as it is. Continue the installation and if you see an error message click on the Ignore button. The installation will finish.

  1. When the installation is finished open in your web browser http://localhost:30304 and refresh the page until you see the license server page. After that you’ll need to login with the email associated with your licenses. You can either click on Online licensing and then on the Sign in button or simply click the blue Sign in link on the front page.

After you are successfully logged in you’ll see your licenses listed on the license server page and be able to use V-Ray.

@danielle.parker1 You work on PC, true?
Probably by some miracle the license server is’t in autostart folder. I had the same problem. Go to Start/All Programs/Chaos group./Chaos license server and run Start Chaos liisence server. Now log in with the email address assigned to the license for the Chaos website and enter the address http://localhost:30304/ in a new browser tab
Wait a moment, it should work.

Copy SCLS to the Startup folder