FaceMe toggle for components already present in model

Hello all.
Is there a simple way to toggle the faceme (and shadowsfacesun) behaviour on a component that’s already inserted in a model?
Of course it is possible to modify it if you open the component as a model in the Model Info.

Ideally, I’d like to toggle the FaceMe property in the Entity Info of the tray (1), and not have to open the component in another Sketchup session, open the Model Info and tick Always face camera and Shadows face sun (2)…

I use SU since v2.1 (so twenty years ago) but I’ve always wondered why it wasn’t possible.
FaceMe is a property you can only interact with when creating the component (thus not accessible when you insert an external component) or when you open the compo itself.

1 Like

You can change that in the component panel as well.
Select the component in that tray and then change the tab in ‘Edit’ .

1 Like

Ok I get that. I was looking in the wrong panel. It is a bit weird to not have that possibility in the entity info panel though. :wink:
Imagine having to crawl through hundreds of components in the components panel to find the one corresponding to the one selected in the center of your screen… counter intuitive, I’d say.

If you select a component, in the Entity Info panel you see its name. Then it is easy to find it in the Components panel.

well… I kind of have understood that you find this normal.

Let me just say that it’s not logical to have to search for the component in the components panel (amongst hundreds of similarly named ones) when the component itself is already selected in the viewport, shown the Entity info panel, and that the FaceMe toggle isn’t available although you already have all these toggles???
Capture d’écran 2023-02-11 133843

I will pass your comment on as a feature request.

In the meantime, I found this free extension:


It only claims to work up to SketchUp 2018, but it still works in the latest version I have.

There is one oddity, at least on my Mac. The tools are not enabled until you go to Tools/Curic/Behaior, and choose Behavior always face camera, for example. Then that entry in the tool palette works ok.

1 Like

This plugin is very handy, thanks Colin! Curic is a tensai!