Face Not Created

2017
sketchup

#1

I have unusual shaped object, was originally a hexagon that the “points” where then cut back so in essence it is a 12 sided polygon, 6 large sides and 6 small sides.

I have a smaller version above the first which is on the XY axis.

I want to create faces on all 12 sides. When I draw in edges from the upper corners to the lower corners some faces are created and some are not.

See the following image.

I guess that means that the edges do not form up correctly to create the face. I have zoomed right in top and bottom in one case and cannot find why this is happening.

Included are zoomed in screen cuts of the top and bottom of one of the “panels” that dod not create a face.

Any ideas?


#2

You could use Round corner plugin


#3

Thank you, It so happens I have that plugin loaded. :slight_smile:

Ken


#4

For extrusion, to not using so many guide lines :wink:

or with copy/rotate 5x


#5

This is awesome, thank you.

When adding the pull pieces on the short sides, you copied once and then the other 4 “magically” happened.

How did you do this exactly?

I am a very new users if you hadn’t worked that out. :slight_smile:

Ken


#6

As I said… select what you want to copy > rotate > copy > type 5x, which means that will be 5 copies of what you select.
There is video tutorial in SketchUp Youtube channel for how exactly use copy command.


#7

My best guess is that the 4 cornerpoints of the “faces that won’t create” are not coplanar. Witch means that there has been made a mistake earlyer on. try to draw a diagonal and see if that creates 2 triangle faces. if so, the 4 points are not coplanar and you’ll have to fix that…

The plugins will do the trick for you, but then you wouldn’t learn from your mistakes :slight_smile:


#8

Thank you @tweenulzeven, I do prefer to learn from my mistakes, thank you.

Is there any way to “easily” make them co-planer?

You are correct, a diagonal does create 2 faces. :frowning:

Thanks you

Ken


#9

@mihai.s, which of the round corner functions did you use and what parameters did you change, I would like my small side to be 4", 2" either side of the current edge.

I am having troubles getting the same result, sorry. :frowning:

Ken


#10

There is no easy way to make them coplanar if you don’t know where you made the mistake.
The small 12 sided “hexagon” at the top should be an exact replica of the bottom one. instead of drawing them separately (which is prone to mistakes) you could make a copy of the bottom one straight up by the desired distance and then scale it to the desired size.
But there are numerous other ways. Just keep in mind that is has to be exactly in the right place and is not twisted in some way.


#11

As shown in the picture, I used the third button, but you can use either of them. The other two buttons let you specify the number of sides you want, and the dimension.


#12

Here’s some usefull information from another thread:


#13

@kencoleau, for your exact dimensions, the first option that comes to my mind is:


I used centimeters instead of inches, but the idea is the same.


Cardinal Points Polygons
#14

@mihai.s, I would like to use the roundcorner option.

See my issue with the boundary on the left, it isn’t on the left face.

I am only selecting one edge for now but the same happened when I selected all 6, I can only suggest one or more of my roundcorner parameters need changing, you can see my values in the top of the screen cut.


Ken


#15

Green lines, and the red one, it’s just for the preview. Go create geometry!
You don’t need that kind of precision (6 digits).


#16

@Fredo6 Can you please explain the difference between what @mihai.s is doing at the top and my issue just above?

thank you.

ken


#17

@mihai.s, I had tried that, it creates a really bad corner and deletes my top face.

Ken


#18

Probably the model it’s too small, or you miss something.


#20

@mihai.s, I found the issue, somewhere along the way each of the edges of my hexagon where actually 2 edges extremely close together, so I went back and started from scratch and I think I now have it.

The model is actually very large, real life size, 9’ sides on the bottom of the hexagon.

Thanks for the help.

Ken


#21

Way to go @kencoleau!! This is the way to learn and avoid the same mistakes in the future.
Happy 3Drawing!