Extension warehouse isn't loading

When I attempt to load the extension warehouse it comes up with this. Is anyone else having the issue or is it something I’m doing wrong?


Ah, this may explain my problem too.

Just tried to use it. It tried to load, then disappeared, and at the same time, logged me out of Sketchup.

Oh well, means I’ll have to have some food and relax instead of working tonight :wink:



Not meaning to interfere with your relaxing evening, but in some cases extensions are also on Sketchucation, or are on the developer’s GitHub page. I needed to point someone to the flatten to plane extension today, and was able to find that in GitHub.


Most of my recent free extensions are on GitHub for instance.

1 Like

Thankyou @colin and @eneroth3

It wasn’t urgent, I just wanted to add some new Extensions to my iMac, to keep it inline with my MacBook Pro.

I downloaded your Make Faces, and it’s brilliant! Should have got it ages ago. Saves so much time.


The New EW is up. Did you try it? Speedy!

1 Like

Excellent! I’ll try tomorrow. Just finished work and called it a night.

Hey! It’s morning there isn’t it? :smiley:

Just gone half midnight :grinning: Although technically it is tomorrow now.

1 Like