Exporting to 3D print, says models are 100's of inches instead of correct size

I started to use the sketchupweb to see what it is like and make a plastic version of a hand tool. I finished, when saving I said yes to purging unused things, but when I tried uploading it to a company I’ve used for printing and it wouldn’t allow me. It said auto rescale failed, that a model that is supposed to be ~9" x 1 7/8" x 1/4" is 743 x 906. I double checked with the tape measure any everything seems correct.

I also tried to make sure there was no internal geometry I missed while making/remaking the parts and when I do the model disappears or gives me a weird look. Originally while working on the parts I could get inside of them and see all internal walls, now it cuts off the models, not exactly sure how to describe it.

I have attached the specific file that I described the size of, but it did give me this issue with all 8 parts I tried to upload. Thanks you in advance!

blade.stl (22.1 KB)

Sounds like you and the printer are using different units. Stl is dimensionless, so it is always necessary to have a match between the units assumed by the creator and printer.

It would be more helpful if you could upload the skp model as well as the stl.

Upload the SKP here or to them? From their email the auto re-scale tries mm, inches, and meters, so shouldn’t the inches have matched in the end? Im obviously new to sketchup and 3D printing.

Edit: they don’t support SKP

Upload it here so we can check why it is clipping.

Here it is, it started this morning after saving everything before bed last night.
blade.skp (96.1 KB)

You have a second component in the model space, remove it and your problems with clipping will go away and your exports should be fine.
You may have that component saved in your template which would cause you to have the same issue in other models.

Wow thank you! Not sure how that got all the way out there. Any chance you know of a trick to easily find it? I’ve tried shift + Z but it just brings me to a gray space but doesn’t show the model. I’ve made sure all is unhidden.

With the one you want in sight use ctrl a to select all then hold shift and click on the good one to deselect it. Hit delete on your keyboard.

Oh duh, forgot about select all. Thanks for everything!

No worries.

By the way, if shift z is zooming out like you said, that is clear evidence there is something out in the distance.


This topic was automatically closed after 91 days. New replies are no longer allowed.