Exported model does not include some components

dae
export
components

#1

Hey guys, I’m a long time sketchup user but new to the forums. Today I ran into an issue when exporting my model to .dae format (I am running the free version). Some of my components did not get included in the export. At first I thought it was just dynamic components, but then I realized I had some dynamic components that successfully exported, and some non-dynamic components failed. I noticed that the components that failed to export had nested components included in them (some fairly deep, between 4-8 levels). When I opened the .dae file in blender, I could see a minimal outline that showed where the outer component should be, but the component is not there. I also tried importing directly into Unity3D, but the components failed to go through to there as well. As I have a rather large file, I would prefer not to have to explode and regroup a lot of different components separately to get them into a shallower nest. Does anyone have any ideas as to why this might be happening?


#2

While I’m not sure what may be causing this, I thought I would ask if you’ve tried different settings on the Export Options:


#3

What happens if you import the DAE back into SketchUP?

If your components are included in the import, then the fault is with the receiving applications.

What importance are the components to your workflow in Blender or Unity? The simplest thing to do would be to explode your model down to raw geometry before exporting (the recipients might not support components or groups anyway). It is easier than worrying about regrouping. There are even plugins to do this.

Anssi