Exported JPGs from SketchUp have transparent backgrounds

Hi all. I can’t figure this one out, so I finally decided to try out the forum and see if anyone’s been running into this as well.

It might somewhat of a niche problem as I think the problem has to do with two programs: SketchUp, and Vectorworks. This has been recurring for the last couple of versions for both softwares.

2D images I export as a JPG from SketchUp will somehow come into Vectorworks with transparency enabled. I don’t want transparency, if I did, I’d export as a PNG. I’m investigating this on the Vectorworks side of things as well, but just thought to ask around here in case anyone’s ran into a similar issue.

It must be a Vectorworks setting. The JPEG format doesn’t support transparency so there is no way that the info could carry from SketchUp via the image. Or then you are exporting to PNG without realizing it. MacOS hides the file type from the user.

1 Like

It only hides it if you choose to: I turned that off immediately and the setting has stayed through OS upgrades. Finder->Preferences->Advanced->“Show all filename extensions”.


I think both Windows and MacOS hide the ugly extensions by default. I seldom have to deal with Macs these days, in old days the information was hidden in what they called “resource fork” and you needed ResEdit to see it.

1 Like

I remember using that.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.