Export Scene to 2D DWG

Is there a way in Sketchup Shop 2020 (web) to export a specific scene in AutoCAD dwg 2D format? For example, when I select a scene with a plan view (e.g. front view), Sketchup keeps exporting the 2D drawing in more of an isometric view.

Try changing to Parallel Projection and the appropriate standard view.

@DaveR

Thanks. I have the parallel projection set. The issue is that the exported view is no where close to the scene. It appears fo be using some default isometric (ish) view. Should the exported 2D view match the current scene?

I would think so. It does that in the Pro version. I’m testing it now with Shop but I picked kind of a large model so it’s taking a little longer.

BTW, you are choosing the 2D export option, right?

OK. Faster than I thought it would be. I have the following displayed in Shop.

I exported a .dxf instead of .dwg but the results should be basically the same. In Draftsight I get this.

FWIW, I exported a .dwg file instead and opened it in Draftsight. Looks the same to me. (I did change the model to show 3rd angle projection.)

@DaveR

I must be doing something wrong. See attached video.

Can you share the .skp file for the table. If you can’t make it public, share it in a private message.

That table looks familiar. I did plans for a very similar one about 7 years ago. Based on a couple of details I left in the model, it actually appears to be my model.
Screenshot - 2_12_2020 , 8_12_16 AM

I think I see what you were missing. Since you have created scenes in the model, you need to select one of them before you do the export. That defines the view you want. I don’t have any scenes in the model of the J-38 key so it takes the current view. Your last screen shot seems to show the Front view selected but…

Here I’ve selected the Front view scene.

Then selected the 2D .dwg export option.

In Draftsight I get the expected view.

2 Likes

@DaveR

Thanks for the reply. Wow, what a small world! Yes, that must be your model. I downloaded the Sketchup model and drawings from Fine Woodworking. Nice drawings by the way.

I am still having problems exporting the correct drawing view. If you look at the video I posted earlier in this thread, I think I selected the scene correctly prior to the export but still get more of an isometric view. Still not sure what I am doing wrong.

Would you mind posting the export settings you are using. Below are the settings I am using.

Thanks.

Here’s what I have after selecting the Front view scene.

And again, the results after export.


Two Way Drawer Dinign Table (1).dwg (14.4 KB)

@DaveR

I appreciate all of your help. I still can’t get it to work. I can open your DWG file and it is the correct projection. All of my export settings match yours so I am not sure what is wrong. I am starting to wonder if it has something to do with the trial license I am using.

The license shouldn’t have anything to do with it. It is weird, though, and I’m not sure exactly why we’re getting different results. I wonder if @Mark might have any ideas.