Export .dwg not accepted by machine shop

export

#1

I upgraded to Pro so I could use the export to .dwg function to send some parts to a machine shop where they would be made on a CNC milling machine. I’ve tried two shops and they are unable to import the files into their CNC software. The import function works but they get a jumble of lines instead of a solid part.

Has anyone had any luck doing that?


#2

what export options and model settings are you using?
john


#3

And it would help to see the model and the dwg you are exporting.


#4

Sketchup Pro 2014 ver 14.1.1282Antenna box.dwg (2.1 MB)
I’ve attached the Sketchup file and the exported .dwg.SORTIE ant production 2.skp (1.9 MB)


#5

In the export options box I have all boxes checked except text.


#6

I would expect a cnc dwg-file would contain only one object per file.
Also, to check if they are solid, make the individual parts into a group. The selected objects (with blue lines) in this image are the ones that are causing problems: they are not solids.


#7

Before I sent these to the machine shop I made each part a component then exported that.

How do you make a drawn part solid?


#8

There are a few problems with your model. Normally you can tell if something is solid by triple-clicking on it and making it a Group. If the Entity Info shows that it has a volume, then it’s a solid. If it doesn’t show a volume, something is wrong.

Some of your parts are ok, but some don’t show a volume when made to be a group. Some of those are because you have bits of geometry sticking out. One in the upper right seems to have been made to look ok by using smoothing, but the geometry is bad. Several places have faces reversed.

So, any faces that are darker reverse them to be more white, and any parts that don’t show a volume when made to be a group have geometry issues to fix.


#9

The object at upper right, labelled “no changes” has several problems. If you turn on hidden geometry and orbit around to look at the other side, you will see a lot of issues with the back face especially around the hole. Also, the sloping face is for some reason not planar. You will see smoothed lines dividing it into a bunch of sub-faces. I’m not sure how you created this, but I would suggest that you redraw this part by copying the front face and pushpulling it to the desired thickness then fixing up the mitered places at the top.

I tried to upload a screenshot of what I mean, but the forum image upload function is still broken.


#10

Also, on the larger bracket in the upper middle of the view, the box marked “moved and larger” on the back has a twist in the outline facing the back of the bracket (again, a screenshot would make this clearer but I can’t upload one). The upper right corner points are 0.001 out of plane with the others. This causes that outline not to cut a hole in the back and SolidInspector2 to report it as a surface boundary.