Explode error

Hello guys
I tried to explode group but It doesn’t work

error report page poped up and sketchup program shut down…
Am I the only one who can’t explode?
I use 2021 version with window
I changed with 2017 ver
Does anyone can help me??

sample.skp (2.3 MB)

Which group are you trying to explode. When I opened your file I found 23 groups and a component inside a larger nested component. I exploded the top level component with no trouble.

The scale of the groups and the fact the frames are made of non connecting raw geometry are the most likely reason for your problems.

1 Like

I wanna leave Component#21 and explode every group except sumel…
I changed another computer but same error happend

As Box pointed out, the scale of the component and groups inside the large component is likely the problem. Fix them before you try exploding.

I have no idea that my friend who use 2017ver can expolde it!
that means it can be exploded I guess
but when he send exploded file to me, it came back without exploded

How did you create these frames? There’s a lot of bad geometry, the frame sides aren’t connected to each other and the scale is incorrect. Notice what happens when you reset the scale on one of the groups.

There’s enough wrong with these frames I think the easiest thing to do is remake them correctly. This is simple enough to do since they all use the same molding profile. You should be able to make one and then copy and adjust the size using the Move tool.

1 Like

all right… I will remake again!
many thanks

As I wrote earlier, if you make one correctly, you can then copy it and resize it. Here I’ve redone a few of them. I started by making the large frame in yellow and making it a component. I then copied it down with Move/Copy, made the copy unique and then I resized it. Then I copied the two over to the side, made them unique and resized. Rinse and repeat around the room.

Here’s the rest of them done. In some case with the frames being the same size you can just copy the components without resizing.