Error Message with Extension Manager: "Oh snap! de/js/app.soy.js failed to load! :("

Hi.
I’m new to Sketchup and give it a try (feels like a very well made software : )

When I try to open the extension manager I get the error message (reproducable):
“Oh snap! de/js/app.soy.js failed to load! :(”

macOS Catalina
SU 19.3.252

Is that a known bug?

Thanks.

Are you behind a firewall or other restriction that might cause the extension manager to be unable to access the internet?

I use a standard macOS with no extra Firewall.
I have access to the internet and I can install extensions from the Warehouse without problems. But I cannot open the extension manager.

Are you using a custom language parameter when starting SketchUp? I have had this issue when my lang parameter didn’t match any installed language.

I just use the standard german GUI. Where can I check/change the parameter please?

This sounds like a bug in the german version. What version are you using?

Since you asked, the language parameter can be set in the shortcut “target”, but I don’t think this is your problem unless you have already changed it.

I’m using macOS and the Sketchup Version 19.3.252

What language and region/country is your system set to?

I just installed the version 2020 now.
There everything works fine.

Thanks for your help.

1 Like

Hello! I apologize for the mistakes. I know English bad. I have a problem - the Extention Manager window does not work. At that, Extention Warehouse opens. Help me please. Windows 10 Pro 64 bit, Sketchup 2018 Pro and Sketchup 2020 Pro

hello
I’ve also got the en/js/app.soy.js failed to load! message shown in the extension manager.

I’ve installed French version by mistake.
I’m using the english version with option language parameter can be set in the shortcut “target” -lang en

No such file in Roaming or ProgramData.
Nor in 2020 folders or 2019 folders.
I used 2019 in english version !

Wrote to the support.
Sketchup Team Please help.

An other problem : From time to time Sketchup goes mad.
My cursor shows an hourglass and wont let me carry on with any command until it releases the pointer !!!

Please help again.
I would like not to have to desable my plug ins one by one.

Repair the SketchUp installations.
Find the installer executables, right-click on them and choose “Run as administr ator” from the context menu. Then choose the Repair option.