[ERROR] Failed to Open Document


can some want help me… When I tried to open it I receive the error message ‘Failed to Open Document’. I’m running SketchUp 2021. my file in the google drive here:


Please help, thankyou

It took two tries to get it to open, it is responding extremely slow while attempting to navigate in an attempt to examine it. Since opening it Sketchup has spent about 10 minutes trying to do a simple zoom extents. I have force-closed the file.

1 Like

It opened for me on the first try. As @RLGL indicates, your file is huge.

I fixed incorrect tag usage.
Screenshot - 7_15_2022 , 4_05_45 PM

And purged unused stuff.
Screenshot - 7_15_2022 , 4_07_19 PM

There does seem to be a lot of overly detailed entourage in the model that contributes to your problems.

1 Like

I downloaded your enormous file (655MB!). It does open on my computer after a delay for processing. I suspect you are bonking into the upper limits of your RAM or Graphics card. However once open it performs very very badly, extremely laggy with the graphics card struggling desperately to process the geometry you have included here. You have filled your model with ridiculously high poly count entourage. The bedding, the faucets, the furniture, the fixtures, the plants, all if it has been dragged in from other sources, probably most from the 3D warehouse without checking the size of any of them. It’s like you just kept loading bricks into your car, first a few, then a few more, some into the trunk, some more in the backseat, stacking hundreds of them on the roof until all the tires go flat, and now you wonder why the car won’t drive.

Look at your statistics, you’re asking your graphics card to calculate 8 million edges, generate shading on 4 million surfaces. This file needs to go on a serious diet, ditch all those high poly components and find lighter weight alternatives. The vast bulk of the model complexity cannot be seen anyway and is simply unnecessary.

1 Like

how can i do the same? I’m trying to open the file, but it doesn’t load, just this error message appears. I can’t clean the file

I expect the main problem comes from your hardware. What is the graphics card? Your profile doesn’t answer that question correctly.

Purging unused stuff in your model only reduced the file by about 12-15%. Better than it was but still overloaded.

Right now I’m waiting for that stupid rug with the tasseled fringes to clean to see if it can be reduced. Nice enough rug if your model is about a rug. It’s an awful component to add as entourage, though.

thanks for yor attention! how can i clean the file? how could i solve this problem? should i’ll make everything from zero? if only I could give a clean up and make it lighter… (sorry for my bad english)

AMD Ryzen 5 3600 Hexa-Core 3.6GHz (4.2GHz Turbo) 35MB Cache AM4, YD3600BBAFBOX

Team Group T-Force Vulcan 16GB (2x8) 2666MHz DDR4

Asus GeForce GTX 1660 Ti 6GB GDDR6 OC Phoenix 192-bit, PH-GTX1660TI-O6G

I don’t have time to do a very carful job at the moment so I ran through the model deleting objects and furniture quickly. In general the fabric goods are adding a lot here: the bed, the pillows the curtains, the towels, those intricate curved surfaces are composed of many tiny surfaces. This collection of folded towels at the foot of the bathtub for instance has over 1 million edges!

With 5 min of deleting the file still contains all the basic geometry and is 63mb with less than 1 million edges. More work could be done to make it better, I suspect that the art you are using is from very high res images, which adds further load to a file.

But as I said I don’t have time to do a careful dissection at the moment, at least this gets you a file with the architecture that you can open.


1 Like

I’ve brutalized the file and removed the bulk of the overly detailed entourage. File size has been reduce by about 87%. It’s still a big file but you ought to be ble to open it. If you are going to reinsert entourage, search for components that aren’t so ridiculously overly detailed.

1 Like

thank you so much! you helped me a lot, I was finally able to open the file. obrigado!


thank you!! I will be more careful next time xD obrigado!

This is a link to a panorama tour of a house, it’s modelled in SketchUp and rendered in Enscape. The entire model (house, furniture, exterior, materials etc) is 301mb in SU22 (bigger in 21 due to compression in 22).

Some of the bigger bits of furniture such as the beds and sofas are proxy objects that only appear when rendering but most of the stuff is std SU models.

If I ever need something from an external source ESPECIALLY FROM THE WAREHOUSE I start a new instance of SU import the thing I want and then explode, gut, cleanup etc etc etc the hell out of it before I’ll let it near ANY of my models.

Here’s another one, this is a video of (if I remember correctly) 26 houses, the entire model is 188mb in SU22, the trees/planting are proxy’s but everything else inc the cars are SU geometry.

Essentially …… NEVER trust anything you didn’t create yourself, always check/test/rebuild it in a separate SU model before you import it into your own.

1 Like