Eraser tool does not "mend" surfaces

Hi all.
I just upgraded from a 2017 version to the latest version. I have been using the eraser tool to remove lines on a surface and when I do the surface remains broken into several pices. My understanding was that the surface should go back to one unbroken unit. What am I missing here?

Sounds like you are hiding the edges rather than deleting them.
Shift with eraser will hide, ctrl with eraser will soften. Both work as a toggle and show an extra bit to the cursor when active.

Option on Mac.

1 Like

Is it in fact “a surface” and not several that may not be quite coplanar?

Thanks for all the prompt replies. I was holding the shift key, as I saw it in a Sketch Up video on their website. Problem solved.