Eraser is deleting everything

I’m trying to erase one object… it worked fine before, but now when I do it, it’s deleting my whole layout!
What the heck? I tried switching between default and every page layers and it does the same thing with both… I backed up (control Z) and re did some things and then tried to erase what I needed to and same result. HELP!!

Upload your .skp file so we can see what you are working with. Is your “whole layout” a group or component? If so, running the eraser over it would erase the whole thing.

OH!!! Thank you!! I grouped some objects to move them… I will ungroup and see if that fixes it :slight_smile: Thank you!!

Yep! That was it! thank you again!!

So SketchUp was doing exactly what it was supposed to do?

1 Like

You shouldn’t need to do that. Just open the group for editing (double click on it, or R-click/Edit (component or group). then Erase any geometry you want to get rid of or replace.

DO get into the habit of grouping or making a component out of ALL raw geometry after you’ve draw a part of your model. If it’s an object in the ‘real world’ make it a component in your model. (Or, less usefully, a group. A group is only a special case of a component, and behaves differently.)

And DON’T tag any edges or faces, and DO leave the Default tag at Untagged ALL THE TIME. There are VERY rarely occasions when as an experienced user you will want to tag edges or faces, but you need to understand the consequences.