Erase stray curves is not working

일러스트2

Everything else works fine in rube edge tools2, but only erase stray curves doesn’t work.
I’ve tried deleting all rubies and reinstalling them, and I’ve also reinstalled sketchup.
What could be the problem? Help.

@thomthom

thank you

Do you have TT_Lib² installed?

yes it is already installed If it is not installed in the first place, the warning keeps popping up.

We may need a little more information… even better to include more relevant screenshot(s) than the toolbar itself…
How is your modell looks like? What you have been selected? What result you expected, and what result you got?

SketchUp 2022… Edge Tools > Erase stray curves works ok


If you press Erase stray curves, the lines should be erased as shown in the video, but there is no response.

In the video you posted it is working as it should. That video is from Mihai and we can see it above your post already.
Would you please so kind to show YOUR model, and show what YOU are doing and what result YOU got?

Erase stray curves Not Work

That look strange… clicking on that icon must give a message box with an info how many stray curves erased. In every case, even there were no curves/edges erased…

I would try to do this:

Start SketchUp, and remove Edge Tools2 and TT_Lib2 by Extension Manager. Quit SketchUp.

Download the most up to date installer (in your case SketchUp Pro 2020) from here.
Download All | SketchUp

Then right click on the downloaded installer file and choose Run as administrator. When prompted, chose Repair.

Start SketchUp and install firs: TT_Lib2 and then Edge Tools2 form Extension Warehouse . Quit SketchUp. Start SketchUp.

1 Like

already tried everything

Can you go to Windows> Ruby Console and open it.

Then see if there are any messages in a Ruby Console while you are click on the Erase stray curves icon?
Also, what happening if you try to activate via menu Tools>Edge Tools2>Erase stray curves ?

Best would be to make a screen record then we can see also…

1 Like

Error: #<NameError: uninitialized constant TT::Win32::OutputDebugString>
C:/Users/UserName/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/TT_Lib2/debug.rb:36:in debug' C:/Users/UserName/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/TT_EdgeTools/close_gaps.rb:70:in erase_stray_curves’
C:/Users/UserName/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/TT_EdgeTools/close_gaps.rb:32:in `block in module:EdgeTools

There’s a bug in the TT_LIB2.

To get around the bug, open the file
C:\Users\your user name\AppData\Roaming\SketchUp\SketchUp 2020\SketchUp\Plugins\tt_edgetools\close_gaps.rb

and delete the Line 63, that reads:
TT.debug “TT::Edges.find_curves took: #{Time.now-t}s”

Save the file and restart Sketchup

Hope that helps

I found the answer

thanks for the help