Eneroth Axonometric plugin


I am tasked with creating my 3D model on sketch up, using the Eneroth axonometric plug-in view, to create an animation for this project. The model is already completed and groups/components correctly made. My model is a box that opens up and out in a specific order, transforming into a building. The issue I am having is when I pull the roof up, it will not snap correctly to the geometry. If I take the axon off, it works as normal. Is there a way I can change a setting to make the axon snap better?

Using a kind of parallel projection, there can occur minor issues (clipping etc., and the distance between viewer and model can become shifted), but I haven’t heard of issues with snapping.

You want to use the axonometric view for the animation. For setting up a scene (key frame), you can still use any other perspective and use the Move tool to move the objects (roof) how you need it. Then you can change back to the perspective of the scene.

Check out the Update Scene button, where you can for example uncheck “Camera Location” and update other scene properties without setting the scene’s camera to your current view.

By the way, are you using a specific animation extension (which?), because you mention you move the roof between scenes?

I used the eneroth axonometric projection.
Usually if you move an object a certain direction it will snap to the red blue or green line. But it will not snap to the veritcal line.


Since the SketchUp camera matrix can’t be directly modified the extension works by distorting the geometry. If you enter the distorted group/component by double clicking it the axes in it should however be skewed along with the geometry and axis inference should work. If you are outside the distorted group/component though the blue axis is not parallel to the one distorted one.

I’m also curious how you make the animation. I haven’t animated much myself in SketchUp so I don’t know what plugins there are and how they work along with my axonometric plugin.

1 Like

This topic was automatically closed after 91 days. New replies are no longer allowed.