Ending an animation on the last scene


#1

Whenever I create an animation, it always returns to Scene 1 when it finishes. How can I get it to stay on the last scene? This is particularly frustrating when I export it to a video file. I’m showing the development of a project from Scene 1 - the existing view through to scene 20 - the final view; but the effect is spoiled if the video always ends on Scene 1.


#2

Loop to starting scene” must be checked on your “Animation Export Options” dialog.

MS Windows: http://help.sketchup.com/en/article/114341
Apple OSX: http://help.sketchup.com/en/article/114336

So uncheck the box.


#3

Alternatively you could play with the page time settings individually, and make a copy of the last page, like:


Back up your model.
Copy the last scene (make it the active page, then right-click and choose Add.)
Move that new scene to the first position.
Open the Ruby Console.

ps = Sketchup.active_model.pages
ps[0].transition_time=0
ps[0].delay_time=0
ps[1].transition_time=0

Try it again.


#4

Thanks for that Dan. Unfortunately, I forgot to say that I’m using SU Make 2015 and don’t get any options. Presumably that only comes with Pro?

Jim


#5

The options are available in Make.
Bottom right corner of the export dialog.


#6

Oops! Sorry. However, all the options are grayed out except for the Resolution box.

JIm


#7

The options that are available, depend upon the “Export type” selected in the outer file dialog.

Try type “mp4”.


Oh, I see that Animation Export is a Pro Only feature.
http://help.sketchup.com/en/article/114334

Sorry.


#8

The 3 IT questions in your profile need updating.


#9

I checked my profile out of interest, none of the entries were marked “IT”. Are IT questions the really hip/happening ones?

I take it you mean the OS, graphics card, and SketchUp version questions. While I was there I added more details to the OS entry. I had previously only put Mac OS.


#10

Yes of course. IT is easier to write than that whole sentence. (I wish the forum engine would keep nagging users who’ve left them blank.)


#11

Hi Dan. I’m not sure what you mean by ‘The 3 IT questions in your profile need updating.’ This is my first post on this forum, so I’m not fully conversant with all the protocols. sorry.

Jim


#12

See the previous 2 posts. Colin nailed it when he observed:

Click your avatar in the upper right, a popup menu appears, choose Preferences.

Scroll down until you see these 3 questions:

The better & more detailed you answer them, the better the answers can be to your questions (especially the Technical Problems type of questions.) (ie, the dim helpers below the fields are there to help you fill them out.)


#13

Thanks for your patience; I clicked on Profile and couldn’t see what you were referring to.

Jim


#14

… not Profile.