Easier way to notch component

This is a v-grooved panel of siding and I’m trying to notch a section of the bottom out (and failing to do it easily). I imported the dwg from their website (Longboard) and used the push/pull for length.V-Groove Siding.skp (324.3 KB)

Basically, the notch is from the bottom left 12" - 24" over and removing the bottom 1" of material.

The only way I was able to do this required intersecting the component with a plane at 12" and 24" and then doing a lot of individual deleting of lines that make up the tight curved edges at the bottom…and with having to do this in my model for quite a few openings it would take me quite a long time - any recommendations/thoughts for a more efficient technique?

The plane I intersect the component with seems to cut through the faces of the component but not the lines, so deleting those faces between the two planes is easy enough, but the planes don’t cut the lines.

To begin, there are some aspects of the model that you should clean up because they will interfere with editing it sensibly. These are almost certainly artifacts of the original dwg import, not something you did specifically.

  • Tags (called layers prior to SU 2020) are not used appropriately for SketchUp. SketchUp edges and faces should always be untagged and only components or groups should have other tags assigned. This is a common issue with imported dwg because CAD layers are used differently than SketchUp tags. You can fix this by making all tags visible, opening the siding component for edit, selecting all, and reassigning everything to the untagged state in Entity Info.
  • The component contains several loose edges that don’t seem to serve any purpose. They should be deleted, as they cause the bounding box of the component to be large compared to its useful content.
  • The axes of the component are located based on those stray edges. You should use the right-click Change Axes command to set the component axes at a sensible place and orientation on the profile. That will make it much easier to work with it.
  • The instance of the component in the model is very slightly misaligned from the model axes. That will also make it hard to work with. The simplest solution for this is to delete the existing instance and bring a new one out from the Components window (after the preceding axis change). Placing this new instance at the model origin will also help.
  • The siding profile contains small, detail features. These are going to cause problems while editing because SketchUp has a tolerance that causes it to merge vertices that are within 0.001" and delete the edges that join them. You need to scale up the contents while doing your edit. The “Dave method” is a very good way to manage this task.

With all that prep work done, the easiest way to cut the notch is to create a cutting component whose cross-section is the 12 x 1 size of the notch and whose depth is greater than the thickness of the siding. Place this at the desired cut location. Placement is a bit awkward because of the curved shape at the bottom of the siding. Turn on view->hidden geometry so that you can see the edges defining the curve and use them to align the cutter’s bottom with the lowest one.

Now, since you have SU Pro, use the solid tools (or better, either Eneroth’s solid tools or Mindsight Studios’ BoolTools 2) to subtract the cutter from the siding profile.

Here’s the result of all that:

V-Groove Siding.skp (404.8 KB)

1 Like

Thanks a lot for the reply and the suggestions. I’ll take a closer look and a shot at cleaning things up this evening when I get a chance. I’m sure I’ll have a handful of questions going forward, longtime SketchUp user (lifetime carpenter, all my SketchUp work has been for projects I’ve built - nothing overly complex), but all self-taught which I’m sure has led to many less than optimal habits.

I’ve noticed this before and sometimes it’s obvious what is causing this and sometimes it’s not. My workaround is to explode the component that is behaving this way, reselecting it, and making another component. Is there anything not visible that would cause this to happen?

In this specific model it was due to edges within the component that were assigned a non-visible tag. Make all tags visible and you see them. Not in this case, but this could also happen from hidden flag on geometry. An unreasonably large bounding box is a giveaway that this is happening.

1 Like

This workaround may cause similar issues in the future.
Why? Because exploding a group or a component results in assigning the group’s (component’s) tag to all its entities (edges, faces, guides, guidepoints, nested groups and components, etc,) that were untagged prior to the ‘explode’ operation.

A better solution would be to clean up the group (component) in its editing context.


Ah, thanks for that, I’ll definitely stop the explode method.

1 Like