Dynamic component material change

dc-help

#1

I am trying to make a dynamic component in which you can change the finishing material. Here is the file I´m working on Cube.skp (198.3 KB)

However, once the component is created and saved in the local folder to be placed in another file, this component “does not come” with the materials that I set it to select (Carrera Marble or Granite Brown).

I downloaded the SketchUp TruckDelivery https://3dwarehouse.sketchup.com/model/6f2c294b84ffe6afde650492e45fb14f/TruckDelivery to investigate how this is done but I could not do it in a way that once the comoponent is inserted into a file it will bring its variations of materials.

Would anyone know how to do this?


How I set the model


#2

You can do this by adding a grouped face in the model, applying your materials and then hiding the said geometry.

Does the component insert with one of the materials?

Please provide your working file and I will have a look. EDIT: Nevermind, you have provided it!

Ashley


#3

You have a [Space] before the M for the material name. That’s the issue.
I have added this to the ‘Value’ column on your drop down list and it is now working.

But maybe you should resave your material without the [space] at the front anyway

Cube REV01.skp (198.0 KB)


#4

This still does not work: I saved your ** Cube REV01 ** as another template to then be placed in another file, as it should work properly but still the same problem, the materials do not show up with the template


#5

Have you tried just double clicking on the REV01 file straight from download?

And also purged your file when you have deleted your old model?


#6

if you import it into a model, you need to explode the top level wrapper…

john


#7

@john_drivenupthewall, @aroberts
What I need is a file that, when inserted into another file, does not need to explode it or have to double-click to get past the first grouping level, but at the same time as that file brings with it the materials that they should come with him.

It is the example of the ** delivery truck ** of Sketchup, once inserted inside another file it is not necessary to explode or enter the hierarchical levels of the components to have access to the materials


#8

Right click and ‘save as’ with the original component whilst in model space. Then try the insertion process again. That should do it.

Try with the REV01 file. Open it , Select component, Right click, Save as. Then drop that file into your main model


#9

This did not work, either. But thank you anyway


#10

Here is the sollution that solves the problem!

When I tried to investigate how things worked in SketchUp’s TruckDelivery I had not found the materials that were hidden inside, so I figured out that there was another more sophisticated way of creating a dynamic component in which to change materials.

Thanks for your help and patience!