DWG export respecting origin


Is there any way to make SU’s DWG export maintain the origin point?



this is something i have been wondering as well.
Because it respects the origin when bringing in DWG files.


For fbx exports I embed my all my objects/groups into a component with its origin set at 0,0,0
I haven’t tried but maybe the same trick can be used for dwg exports?


I suppose that would be viable the work around.


Thanks, I’ll give it a try, but Trimble really needs to get DWG export refined if it wants SU to be a professional tool. We should be able to select indexed colors for our layers, and SU should output DWG based on our model layers. Clean and simple. I’m on a mac and there’s no ACAD SU importer. I shouldn’t have to spend hours making backgrounds for my consultants.


should lead to exact results correctly referenced to the origin:

  • switch to top view
  • switch from perspective to parallel projection
  • export as 3D model (even with 2D geomtries only)
  • set DWG option to scale 1:1



It doesn’t, or at least not on my version 15.3 on my mac. I mark the origin with a cross hair and it never exports with the crosshair at 0,0


how did you have evaluated this?

don’t re-import again but use an external DXF/DWG viewer as e.g. the free Teigha Viewer for doing this.



I export DWG from SU in the normal manner and open the file in ACAD…?


The SU model origin will be the origin of the exported file if you export as a 3D model. If you export as a 2D image it will not. The same goes for layers.
Note that the model origin point doesn’t move if you move your axes location (is this what you mean by “crosshairs”?)



Thanks Anssi. The problem is outputting orthographic flat DWG and loosing the origin reference point.


I doubt this, can you provide/upload a small SU sample file as well as the according DWG.


I’ve exported the plan as DWG and I open it in ACad?


and you should be able to understand the difference between files for troubleshooting and a jpg.


And you should be polite enough to understand that I don’t want to share a professional project that is under an NDA. The JPG indicates the issue. The DWG opens the same in multiple cad programs.


Not to worry, if you’d mentioned that I wouldn’t have asked. I won’t bother to ask in future.


For me it works just as expected.

  • File menu>Export>3D Model >> DWG creates a file with ACAD origin matching the SKP model origin
  • File menu>Export>2D Graphic >> DWG creates a file with the ACAD model origin placed at the center of the exported lines.

See the simple example files.
test1.skp (72.7 KB)
test1.dwg (13.7 KB)
test1_2D.dwg (13.8 KB)



To me it seems that you have used the “2D Image” option to export.



Hi Anssi, yes, that’s what I’m doing. I only have ACad lt and draftsight 2D so I can’t manipulate the 3D model in a cad program to generate backgrounds. Is there another way to do it?



If what you have drawn in SketchUp is a flat 2D floorplan, exporting it with the “3D model” option will not magically make it any more 3D than the “2D image” option would. All DWG files are 3D files, there is no separate 2D file format.

The difference is that the 2D export takes what is seen on your screen, flattens it to the zero elevation and exports that as a DWG file - the result is comparable to printing an image.

AutoCad LT has no problem with files that have a third dimension, it only lacks the tools to create 3D surfaces or solids.

The good thing about exporting to 3D is that your layers, if you use them, are preserved, and circles and arcs are exported as true DWG circles or arcs instead of being split to line segments.

For 2D exports the only solution is to mark the origin in SketchUp with some geometry, and, then, in AutoCad, use that to move the exported lines to the correct place. It is a bit annoying, but would take about a minute, much less than the other required cleaning takes. Usually you need to sort the whole thing out to different layers according to the layering convention in use in your profession, as the layers 0, ProfileEdges and SectionCutEdges (the only possible ones in a 2D export) usually are not enough to clarify the meaning of your lines to the people who need your file.