Duplicate page won't show different scene from original page

I have a two page Layout document. I’m trying to add a third page showing the same model, but with a different scene, and with some different Layout layers showing.

I’ve duplicated the second page, turned off one set of dimensions (from the original page 2 named Footings), then selected the duplicated viewport on p3.

When I change the scene on p3 from Footings to Foundation Walls, page 2 also now shows the Foundation Walls scene, not the original Footings scene.

How do I get the two pages to show different scenes?

Foundations v1.2.layout (3.4 MB)
I’m pretty new to Layout, and still finding my way around it, but I thought that this procedure should have worked.

It’s because you have the viewport on the shared “On Every Inside Page” layer. That means the same content will be displayed on every page. Instead you should have an unshared layer for the SketchUp viewports.

You can tell that the viewport is on the shared layer by the maroon bounding box when it is selected. If it was on an unshared layer, it would show as blue.

That simple! Thanks, Dave.

As you can see, I haven’t got the hang of Layout yet.

I wonder why the second page viewport got assigned to that layer? I don’t remember doing that, but I must have by accident.

Thanks for that tip, too - I didn’t know that.

You’re welcome.

FWIW, you can create a new layer for the model viewports, right click on the viewport and move it to that layer. Then copy the viewport and paste it on the other pages. After that you can change the scenes for the viewports as needed.

By the way, are you planning to leave the gray background color to print in the LO document?

Sounds like a good way to fix it. Is it your practice generally to have a separate layer for the Viewports?

And what is the role of the Default layer? Does it tie visibility to that page only, or act more like Untagged in SU?

Probably not intending to leave it to print, but to a degree it is useful for clarity on screen. It makes the foundations and footings stand out visually.

I expect there’s an option not to print it, either in Document settings or the Print dialogue, but I haven’t explored that yet.

I’ve just bought Matt Donley’s book second edition, and will be following that, but I haven’t read it all yet.

Yes! Absolutely. I often stack viewports so I will have more than one layer for viewports. Only one viewport per layer in a stack.

That and the other layers are just added as samples in the various OEM templates to give you an idea of how to set up layers. You don’t have to have a Default layer. You can rename it or delete it if you want.

If the layers are not shared, you can use the same layer for the same kind of content on each page. You have two different dimension layers. Are those different dimension to be shown on the same page? If not, you can get by with a single Dimensions layer.

Shared layers would be used for things like page borders, title blocks, page numbers, etc.

No. Again, it’s just a layer. It could be called anything.

When you get to the point where you don’t want the background, edit the style in the model and turn off the Sky. Then in the Styles section of the SketchUp model panel you can turn off the background. It looks like you have a lot of copies of what amount to the same style in your model. I expect you can delete most if not all but one of them.

You need to turn it off in the SketchUp Model panel if you don’t want it.

Hmmm. Tried to revert to yesterday’s Layout file (from Time Machine), to get back the cover page. But when I open it and try to add a layer Model Viewports, and go to p1, Layout crashes repeatedly.

Will have to recreate the cover page, I think, which uses a different Title template at the bottom of the page, not the same one as I used on the inside pages.

I wonder if you first need to save that older version somewhere other than in Time Machine first.

You really ought to make your own template with the layers and content you need.

It looks like the cover page does exist in the file you uploaded anyway. You just need to change which layers are displayed.

That probably arose as I added scenes and edited tag visibility in the original SU model, and would have been prompted to Create as a new style. But I’ve been swapping models back and forth with Michael, the original designer of the dome house (@Earthling on the forum), and it may have also arisen when he edited or added scenes.

Does Model Info/Purge unused get rid of the duplicates? I haven’t, I think (nor has Michael) deliberately created new styles.

PS. Purging only removed one style from the In Model styles window. The rest remain, as variants of the default Architectural style

Only if they aren’t used by a scene in the file.

Typically those new styles arise when you’ve modified the style slightly, create a scene, and choose to Create a new style when the warning pops up.

That would be what has happened. Not quite sure what the details of the differences were, aside from different tag visibility - but that only creates a new Scene, not a new Style, unless something else changes, if I understand that correctly.

It could have something to do with turning on or off sections or something similar.

I have adapted two of the default Title templates, to show some AutoText about the project name, page titles, etc.,and saved them in a new template, but I don’t yet know enough about Layout Layers to know what else I should set up by default. Feeling my way - this is only the second or third project on which I’ve used Layout at all, and the others were all pretty simple, with only a couple of pages.

Any suggestions of layers or other things you commonly include in your Layout templates would be very helpful.

This Layout file will have quite a lot more pages - at least one for each eventual scene (though the later scenes are likely to change in both number and content from the current SU model). And the dimensions are likely to be specific to each scene - I’ve started to separate them between p2 and what will become p3.

And there will eventually be a whole new dome to add, on the ‘left’ of the passage in the current model.

This is the layers list for one of my templates.
Screenshot - 5_28_2021 , 12_00_30 PM

All the page border and title block stuff is at the bottom and locked. I’ve created custom auto-text items to fill the fields in the title block so I add those things in Document Setup and never need to unlock those layers. This template is for a large sheet size and the client folds the sheets for packaging. I added the fold lines so I know where the creases will be. That layer gets turned off before export so the fold lines don’t print.

The dashed lines layer is actually a hold over from before dashes were available in SketchUp. It still gets used for misc. stuff. Dimensions and Art Text (which is for labels and project specific text is at the top of the list so they don’t disappear behind other content. And the Model layer is active. The first content I add to the document is always the Sketchup model so with the Model layer active, the first viewport goes on the correct layer right away.

So you don’t need different layers for dimensions on different pages. Use the same Dimensions layer throughout.

When I tried that on my first attempt to set up p2 and p3, the plan dimensions for the Footings page 2 also showed up on p3, where I don’t want them. What keeps one lot of dimensions to their own page? Is it just a matter of making sure that the Dimensions layer is set to show only on one page - the current one?

PS. When I open the recently saved v1.2 layout file, that too is crashing. Maybe I need to restart my computer, and/or download the original v1.2 layout file I uploaded to the forum in my first post in this thread.

The dimensions would only show up on the next page under two circumstances. 1. the layer is a shared layer like the On Every Page layer or b. you duplicate the previous page instead of just creating a new page.

Thanks for the explanation. I did duplicate the previous page.

There you go. Probably better not to duplicate pages if you’ve added a lot of page specific content.

You can also rightclick and select ‘all on layer,’ than copy paste inly that content.
Another reason to set up up your own system