Drawing cylinder, SU Pro 2018, Mac High Sierra

Since loading SU Pro 2018 I find that I cannot create a cylinder (pretty basic, right?). I have drawn a circle and then used the Push/Pull tool to pull the circle out. But, all I get is a full circle in the direction I pulled and a half circle where I started. Nothing in between these two figures. I tried pulling both with and without holding the Option key, same result. I would really appreciate some help with this, SU is not too useful without this feature.

Choose View>Facestyle>Shaded With Texture

does this happen in an existing model or in new, empty one?


Can you share a small sample .SKP model file that shows the result after the odd Push-Pull behavior? (Use the seventh icon form the left, an up-pointing arrow.)

Does it look something like this?

If so, edit the style you selected and turn on Profiles. Then update the style.

With Profiles on and set to 1, it should look something like this.


Dave - thanks for the reply. I opened a model I have been working on and checked the style as you suggested. Profiles was set to “2” so I reset it to “1” and the cylinder worked exactly as it should. I appreciate your help.


If Profiles was set to 2, it should look more like this.

1 Like

Could you provide a screenshot of this setting?
Meaning: setting ‘1’ to profiles?

Mike - check the first message from Dave, he included a screen shot. Worked great!

Phil Ruffner

1 Like

Yee, I did see Dave’s profile😄
I was intrested in the the one were the edges are turned off and the profiles set to one.

It should be noted that you get that “ghost” effect only when the Style is set to “Hidden Line” mode. Any style that shades faces will show the surface of the cylinder, just without side boundaries if profiles are off. And wireframe will “look through” and see the back edges because faces aren’t shown.

With edges turned off but profiles on, the front part of the upper circle vanishes but the rest of the outline is shown because it is the boundary between the surface and open space.

53 AM

FWIW, the native default Hidden Line style is set up with Profiles turned off. Personally I would edit that style and turn on Profiles. I like Profiles set to 1 for working although there are times it’s useful to display profiles at 2 or 3 when drawing. Most of the time heavy profiles are reserved for display, image export sorts of things.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.