Drape tool

I am having an issue using the drape tool in SU Pro. I uploaded an example model showing the progression of my workflow. In the first scene there are six identical cylinders, moving through the flow from left to right, with the far right being the result of applying the drape tool, which is not at all what I expected. In the second scene I turned on the “color by axis” option to try to troubleshoot. As can be seen doing this, it appears that the tool draped only those lines which are on one of the axes and ignored those that are not. Additionally, when the cylinder is rotated it shows that the tool draped the letters on both the top and the bottom of the cylinder. I am stumped and will appreciate any help the SU community can offer.[Drape tool example.skp|attachment]

(upload://3UPZYZhSiDVVJUXEsPQGYDR9ZD8.skp) (126.0 KB)

Your attachment didn’t attach.

Without seeing your model, is the geometry you’re trying to drape located vertically above the geometry you’re draping on?

Drape tool example.skp (126.0 KB)

Two things. Make the text a group or component so it’s easier to select after starting the Drape tool. And work at a larger scale. There are short edges on the text that will create problems. Scale up, do the Drape step and scale back down.

Dave - thanks so much for the quick reply and advice. I tried it and it worked just right. Problem solved, color me happy!