Double sided Materials option in Collada Exports from Sketchup not working?


#1

Having a few problems here with double side materials…

I’ve just created a single rectangular object, and applied a texture to one side. Exported it to Collada with “Export Two-sided faces” not set. And saved the file.
Then set the “Export Two-sided faces” and saved again. I then compared the resulting 2 .DAE files using Beyond Compare, and there appears to be no difference (except the internal timestamps, and the texture path)

If I then apply the texture to both faces of the object, and repeat the export, with “Export Two-sided faces” set / not set, again there is no (effective) difference between the files.

Is the “Export Two-sided faces” actually doing anything?

Comparing the files with one versus two faces textured, I can see the differences which look like it creates a second object co-planar with the first. It also seems to add a lambert color in addition to the existing material, which I didn’t really ask it to do…

Are there any plans to allow the double sided material to be specified in the Collada data using

DOUBLE_SIDED 1.0

as per the Collada 1.4.1 document?


#2

Same issue here. Actually when checking the data, it’s like you can’t turn off “Two-sided faces”. There are always 2 identical faces with just different orientation. This causes problems when you need to render them with back-face culling off, which I do. This used to work and now it’s broken. Can you please fix it?


#3

Same issue here. A fix is highly desirable.
Thanks!


#4

I looked it up. Long standing bug. I’ve attached this link to the bug, and we’ll see if we can up the priority. A few workarounds on the internets, and mine probably wont help you (grep, vim, etc…).


#5

For the time being, I would gladly descend to some workaround. I have full power of programming at my hand, however I haven’t found a way to distinguish between front and back faces in the exported DAE file. A hint or a link to some workaround would be highly appreciated. Thank you


#6

Hey @Barry, any update on this?


#7

Does this thread help: Monochromatic materials not displaying in GE


#8

I’m facing the same issue. We are exporting to Collada, with double sided faces disabled in the export options. Yet, SketchUp exports everything double sided. Is there a fix in the making?


#9

I’m having the same issue, but there is a somewhat annoying workaround.

If a face is painted with a back colour, then that face will be exported twice, regardless of whether or not the ‘Export Two-Sided Faces’ option is ticked or not.

And when it exports that face, it can’t reverse the winding order in the triangle indices. Instead it needs to write new points because the normals are being reversed, so that effectively doubles the size of the exported dae file.

The workaround is to simply (un)paint the back-faces with the default (null) material.
The Collada export will then export correctly, assuming ‘Export Two-Sided Faces’ is not ticked.